Restart Fixlets not working in Baseline

Hello! We are new to IBM BigFix and our having some issues with the Restart Fixlets not working.

I’ve tried the “Restart Needed” and the “Restart Needed - Triggered by a BES Action” at the beginning and end of my baseline. Updates seem to install ok but the Restarts do not run at either time. I’ve opened a ticket with IBM and he suggested I post some lines of code in the baseline here and see if anyone else has run into this. I’m not sure all the code he asked me to post will post but I’ll give it a shot.

Any help would be much appreciated. Thanks in advance.![


Refer the below post and it should help you out.

Thanks for the reply. I checked the Restart task and that option is checked. I’ve tried two different Restarts and they’ve both done the same or should I say not done anything. :slight_smile: Or are you referring to changing the relevance to “True”? I’ve uploaded screenshots of the two tasks.

Thank you for your assistance.

By looking at your baseline, the restart will happen only when a machine goes to “pending restart” status or else it wont restart. For example: If your baseline contains any of MS security updates then your restart task will work, if not it wont.

If you really want to do a mandatory reboot, modify the relevance to “true” and keep the action script as

restart 10

This will restart the machine in 10 seconds.

On the other hand you have post action behavior, you could simply remove these restart tasks from baseline and choose as shown below,

I hope it helps you out.

That’s what’s weird is these “Restart Needed” Fixlets do say they are needed.

I guess I will try to copy the Restart Fixlet and adjust it the way you recommended. I have used the post-action on my baselines and that worked but I was trying to go off what IBM recommended for best practices. It would be nice if they rebooted before patching if needed.

Thanks for your assistance! If you can think of anything else please let me know.

Would you be willing to share screenshots or your settings on the Restart fixlets\tasks? I’d really like this to only reboot if one is pending.

Thanks again for your assistance.

I usually have this at the end of the baseline for a force reboot, but you have to be cautious in how you use it. My use-case might actually differ from yours,


Relevance 1 : You can also replace “true” with “pending restart” incase you want to restart machines that actually is pending a reboot and incase if you want to forcefully reboot, use “true” as it is.