Pending restart status issue

Hi All,

After done the patching activity in TEM the server status are showing pending restart.
after done the several reboot still the server status are showing pending restart only for along time also the action was not expired, not stopped by anyone still the action is in open status.

kindly give a solution to fix this.


Run this line on your client to filter out some of the excessive file renames that trigger pending restart status.

setting “_BESClient_ActionManager_PendingRestartExclusions”=“drivers;DRIVERS;\spool;.tmp;” on “{now}” for client

Just don’t use {now}, use {parameter “action issue date” of action} to make sure that settings are always in order of issue

1 Like

What if you don’t have “_BESClient_ActionManager_PendingRestartExclusions" as an option in the Computer Settings?

You can just type it in.

Or take this action on the client(s):

setting “_BESClient_ActionManager_PendingRestartExclusions”=“drivers;DRIVERS;\spool;.tmp;” on “{parameter “action issue date” of action}” for client

1 Like

Turns out the issue is with Hytrust, which has its own registry key related to Pending Restart. We’ve reached out to both HCL and Hytrust support. Hytrust states the registry key must remain. Anyone have experience with Hytrust.

Alan, if you don’t know what is causing the pending restart state and you just want BigFix to ignore this , is there a wild card setting? Would this cause issues of some sort?

With the setting _BESClient_ActionManager_PendingRestartExclusions=:; all entries in the Microsoft registry key HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations are ignored because every entry is a path containing a colon. Using this colon followed by semicolon value, this is a wildcard approach that some customers have used with this client setting.

1 Like