CENTOS, BigFix Server, and "issues"

Evaluating and learning BigFix – using Centos
“Too expensive” for a scratch license of RedHat - so choose the latest CentOS (I was told they are meant to be functionally equivalent)

a) I was quite happy with the initial start of BigFix 9.5 on CENTOS, and want to emphasize - largely still am
b) First issues with BigFix Labs - relevance is only for Windows and “Red Hat” - applied lessons on copying tasks/fixlets to change relevance (substitute “Red Hat” with “CentOS”)
c) stuck more here, as the message does not really say anything.

What error is this - can anything be done?

p.s. I have tried going back to sites, removing all computers (and wait), and then from BigFix Management go to the enabled external site, using remove, and waiting before reinstalling (gather needs to be done again, and both activation steps are repeated) - same error message.

Is there something specific to CentOS that the “Manage Plugin” area will never “load” so that I can load the additional Plugin support I desire.


Please try to reinstalled flash player.

Do not understand the logic - but I’ll try to get back there. Was on vacation. Will have to start over again. Had already re-installed with RHEL before reading your suggestion.


Just FYI, you can modify/replace the /etc/centos-release file (i.e. CentOS release 6.6) so that it reads with RHEL details (i.e. Red Hat Enterprise Linux Server release 7.3)? I’ve done this before on a CentOS root BES server and it worked fine. Obviously this isn’t technically supported, but it’s definitely a cheaper alternative for a POC, temporary or non-production BES environment.

I know you’ve already re-installed on RHEL, but perhaps this will help you in the future.


1 Like

Thanks. Excellent hint.

And amazed!

This has been an amazing hint - as it has “saved” me many times being able to play in a safe, even though non-supported environment.

Also, it seems the only core issue was a plugin (a download plugin) that would not start without the trick mentioned above.

I even managed to get my first experience with BFI to work (9.2.14), but sadly, the install script(s) for BFI are looking much more closely for a real RHEL server.

IMHO: it would be fantastic if CentOS could also be accepted (or at least not refused) as a platform for non-production use.

1 Like