BES client cannot register to local relay after relay installed

(imported topic written by RadekChan)

BES client cannot register to local relay after relay installed.

It was working fine when relay did not installed. I think the problem is the register server changed to

Any idea how to fix it or can I configure it not connect to

RegisterOnce: Attempting secure registration with ‘^fe80%3A%3Adcad%3Abeff%3Afe69%3A2929%2F64_0

RegisterOnce: GetURL failed - General transport failure. - ‘^fe80%3A%3Adcad%3Abeff%3Afe69%3A2929%2F64_0’ http failure code 0 - registration url -^fe80%3A%3Adcad%3Abeff%3Afe69%3A2929%2F64_0

The URL is working fine if I use real ip instead of


: (52) Empty reply from server










No WakeOnLAN adapter selected.

(imported comment written by Raja9109)

I/m also facing similar issue in LInux Relay after installing 9.0.649

(imported comment written by ToshikiMatsui)

Have you restarted both processes in its machine?

(imported comment written by Raja9109)

Yes . Already tried all the Possibilities :slight_smile:

(imported comment written by martinc)

What happens when you ping you loopback (

When I look at my relays and the client logs, most show the and they are working. I wonder if there is a firewall issue somehow blocking the loopback.

(imported comment written by Raja9109)

I’m able to ping using loopack address and firewall is in disabled state. The issue is only with 9.0.649 early it was working fine with 8.2.1372

(imported comment written by martinc)

Not sure if this is it or not:

There were some relay fixes addressed in 9.0.777+

* Fixed issue where Relay is unresponsive during RegistrationList upgrade (issue #58548, APAR: IV45378)
* Fixed issue where Relay posts incorrect Content-Type causing report send/receive failure (issue #58808

I do not have an 8.2 build that I can try to upgrade and see what happens. I am currently on 9.0.787 and my relays seem to be functioning correctly.

(imported comment written by Raja9109)

Thanks for your valuable suggestion. This issue is happening only on few Relays . I logged a PMR with IBM and awaiting for response from them.

(imported comment written by martinc)

No prob. I was going to suggest the PMR route :slight_smile:

Couple things they will probably ask (if not already)

  1. Turn on the debug logging for the agent. (BES Client Setting: Enable Debug Logging).

  2. Consider an upgrade (sorry LOL).

I wonder if you can set the agent to manual and set the relay to a different relay. Just to see if it will complete the registration.

(imported comment written by RadekChan)

The other clients which connect to the relay are working. The problem is just the client connect to its relay.

So, wonder if we can set it not to connect, and using other IP/FQDN.

(imported comment written by Raja9109)

Hello Martin,

I have not received any update from IBM yet. After relay installed , the client default behavior is connect through locally (127.0.01) i dont think so we can change this.

(imported comment written by martinc)

Can you try the command:

telnet 52311

and then try

telnet 52311

I am sure that the second one should connect, but the first one should fail. If that is failing, we have some other networking issue on that system. I think this is where to start. Find out why it is not listening to port 52311 on the loopback.

All the remote systems would be using either the FQDN or the ip of the relay to connect. It is only when the agent is on the same system as the relay that it uses the loopback, so this is something unique to a relay system.

Do you have the system set to automatic or manual relay config? If it is manual, then you could try automatic, but I think you would have to manually set up the registry keys since you probably cannot execute actions on it :slight_smile:

(imported comment written by RadekChan)

The localhost telnet is working. So it seems like the software problem.

I updated the client and relay to 9.0.787.0, but still the same.


Connected to

Escape character is ‘^]’.

The client seems like listening, but not accept register.



Version 9.0.787.0


curl: (52) Empty reply from server

(imported comment written by Raja9109)

Whatever Mr.Chan said, The same things happening in my Linux Relay box as well.

(imported comment written by RadekChan)

This time I tried to downgrade to 9…0.586 and still the same.

I am thinking would it be OS version problem.

The Relay/Client rpm is for RHEL 5 and my server is RHEL 6.

(imported comment written by RadekChan)

Well… I downgraded the client and relay back to 8.2.1409.0. And it looks like working fine…

So I think it should be a bug in version 9 ?

One more information is my problem “relay” server is connecting to a “top relay” server. Would it be the point that problem happened?

Raja9109 , are you the same?

(imported comment written by RadekChan)

I found the problem in debug log.

I am testing version 9.0.787 now.

When I start the relay, the client is able to connect to my top relay due to besrelay.conf

And after awhile, the client register again.

This time the client direct register to IEM server instead of my top relay. Since the client do not have network connection to the IEM server. So it cannot be registered.

So the point is why the client will register to IEM server, but not top relay after the first register.

I stated top relay in besrelay.conf

[Software\BigFix\EnterpriseClient\Settings\Client_Enterprise Server_ClientRegister_ParentRelayURL]

Relay Selection: Attempting to register via local relay to potential parent.

(imported comment written by Raja9109)

The same thing happened in my linux relay box as well.

(imported comment written by Raja9109)

Hi Radek,

did you find the root cause? I’m not getting proper response on PMR which i raised for this issue.

(imported comment written by RadekChan)

No… :frowning:

Only can identify the problem is the client “Attempting to register via local relay to potential parent” to IEM server instead of my top level relay.

But not yet found the solution.