Windows update could not be installed because of error 2149842967

Hi experts

i am facing issue with windows update, when i look into event viewer i can see the below error

Eventlog - Windows update could not be installed because of error 2149842967 “” (Command line: ““C:\Windows\system32\wusa.exe” “C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData__Download\Windows6.1-KB3212642-x64.msu” /quiet /norestart”)

and i cannot logoff the server, if i logoff the server then server is rebooting automatically , i need to always disconnect the session.

Experts guide me to solve this issue.

This is not an error coming from BigFix, but rather one from Windows Update. You should see the same error if you tried downloading and installing the patch manually on the endpoint. There seems to be a variety of causes ranging from the Windows Update service being disabled to severe corruption on the affected system. A google search on the error code should give you different options you can try to resolve the error.

A hint - you can use Calc (in programmer mode) to translate this return code into its hexadecimal equivalent, which is the code that would probably get better search results.

2149842967 = 0x80240017
0x80240017 WU_E_NOT_APPLICABLE Operation was not performed because there are no applicable updates.

I’ve seen that sometimes when there is a disagreement between the update package and BigFix as to whether a patch needs to be applied. The Windows Update service has a tendancy to do an incomplete check (ie checking a registry key that indicates whether the patch is installed), while BigFix tends to look at all the patched file versions and will make a fixlet Relevant if one of the patched files was rolled-back or replaced by another process. The easiest thing to do is usually to make a custom copy of the patch, which will first run the uninstall and then reinstall the patch, restoring the health of the affected files.

That can be as simple as
waithidden wusa.exe /uninstall .msu /quiet /noreboot
waithidden wusa.exe /install .msu /quiet /noreboot

The other possibility is a corrupt Windows Update repository. Some possible resolution steps are detailed at