Why the new masthead.axef does not work

(imported topic written by bigbao91)

i use

besdownloadcatch -m masthead.afxm -x sha1

to download fixes.i find that when i use masthead.afxm exported by administrator tool does not work correctly it report

scanning masthead for site masthead.afxm for download actions Masthead scan complete,downloading and catching…

but actually it does not download while i use original masthead.afxm which i get when i installed the bigfix server at first time ,it work well.

i try to use

besdownloadcatch -m BES Suppot.efxm -x sha1

it reports "scanning masthead for site BES for download actions masthead BES does not exist .

can anyone explain it ?

ps:i have updated BES server from 6.0 to 7.0 and i find my web report haven’t any data

(imported comment written by sthull)

Hi bigbao,

The only difference between the two masthead.afxm files should be the existence of operators in the current one exported from BESAdmin. It’s possible that the BESDownloadCacher doesn’t parse the masthead properly when there are operators included. Can you open a support ticket so we can investigate that further with you?

The BES Support masthead probably fails because it has a space in the name and you did not use quotation marks. Try:

besdownloadcacher.exe -m “BES Support.efxm” -x sha1

For Web Reports, it sounds like your database connection was disabled during the upgrade. Check the ‘Databases’ page in Web Reports and see if the database name is in


. If so, edit the database connection and uncheck the ‘Disable database’ checkbox.



(imported comment written by bigbao91)


I have tried:

besdownloadcacher.exe -m “BES Support.efxm” -x sha1

but it is same as no quotion masks

how can i open a support ticket?

The,Web Reports is ok when i uncheck the ‘Disable database’ checkbox.

(imported comment written by sthull)

Please send an email to enterprisesupport@bigfix.com and provide a description of the problem including the command your running and the resulting errors/messages. Make sure that “BES Support.efxm” actually exists in the same directory as the besdownloadcacher.