WebReports - No 'Save Report' button

Has anyone ever seen where the administrator of Web Reports (v9.5.4.38) has no “save report” button when creating a custom report? Save Report button exists when I’m on other tabs under Explorer Data, but not when on the “Custom” tab. Works fine on 4 other WebReports servers running, but not this one.

Working on “Computers” tab…

Not Working on “Custom” tab…

1 Like

I don’t think I have seen this issue myself, but I haven’t tried it on that particular version.

Which browser does this happen in? Can you try other browsers?

Also, try to disable any adblockers or similar extensions for the web reports location / domain.

happens in chrome and IE for me, with add-ons disabled. Same results on a different PC. Same results on a 3rd PC with FireFox (different user’s PC).

I have the same situation.
I have on Japanese Windows Server 2012R2 and I don’t see Save Report button on Custom page with IE11.
Per the DOM Explorer, both “Save Report” and “Save Report As” buttons have style of DISPLAY: none on Custom page.

1 Like

Please check if this is the issue in 9.5 where to create a custom report, it has to be enabled via a Registry key.



Thank you!
I have forgotten to set registry. After changing registry value, I see Save Report button on custom page.

1 Like

Yes, that fixed it. Thanks Leewei.

One slight modification should be made to the ibm doc. The doc say this the product administrator must set the value of key AllowCustomReportCreation to 1.

That might be confusing to some. AllowCustomReportCreation is not a registry key, but a REG_SZ in the BESReports registry key. Same goes for AllowUserViewCustom.

1 Like

Got it @cstoneba, passing info to @Doczilla.

I created fixlets to resolve this issue automatically:

I also submitted a Pull Request to get these added to C3: https://github.com/strawgate/C3-Platform-Kickstart/pull/5

I was not aware of this change and it caused me pain until I figured this out.

1 Like