Webreports Caching Issues

I ran into a very strange webreports caching issue on

When querying a retrieved property for a computer via the webreports API, I get an old, out-of-date result. However, if go to the webreports site in my browser and navigate to that particular computer, the next time I run the webreports query, the data for that particular system is up-to-date. It only updates that specific system though, so other systems still have old data.

I assume this is some sort of caching issue, clicking “refresh cache” sometimes seems to help, but I am not sure why its not automatically refreshed. I had seen an error message in the webreports UI earlier in the day about a background thread dying. Maybe this prevented automatic cache refreshing?

I am sure restarting the webreports server will temporarily fix it, but I am not sure if the issue will pop up again and make my data stale again.

Has anyone else run into any issues like this before?

I’d suggest you contact support to see if they can help as there will need to be a lot more information gathered to know why this might be happening

@grlucche did you ever figure out the issue? I’m seeing the same thing.

Nope. Just set up a bigfix action to restart the webreports on a daily basis, which seems to fix it pretty well.