Web report Export to PDF Issue

I’m facing issue in webreport . Its working fine but when i click on export to PDF button, page cannot be displayed is shown up.

Following are registry settings

Following is a screen shot of server edit properties

Can anyone please tell me if I’m missing anything ?


1 Like

Me too
Windows server 2012 r2
Bigfix 9.5.4

@jgstew @Aram @leewei do you guys have any idea regarding this issue ?

@selimgoksu did you find any solution to resolve this ?

Yes, apply these steps, please.

Specially, don’t forget to add a printer named BES Web Reports Printer and to select the driver Xerox ***


1 Like

@selimgoksu thank you for the link i will verify the steps. Secondly I already have mentioned BES Web Reports Printer in registry settings

Can you see the printer in devices and printers page?

@selimgoksu yes printer is mentioned properly in registry settings. only thing which I noticed is out.ps file is missing in my __pdf folder ? How can i able to generate a out.ps file ? I guess its the real problem which I’m facing

Please check the link below again. After you add the printer with right driver and settings, It should create the file in the folder you specified.


(Images cannot be seen but texts are enough)

I had to click the button “Windows Update” while adding printer in order for the desired driver (Xerox Phaser 6180MFP-D PS) to appear on the list.

and check the values under the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers

Can you see the printer “BES Web Reports Printer” in here ?


Sorry I didn’t respond. I haven’t been keeping up with the forum like I used to. Been doing a lot of publishing content primarily and dipping in every once in awhile. Definitely feel free to @ me if you don’t get a response after a while on something and I’ll get around to it eventually. I used to follow 100% of the posts in the main categories, but I haven’t done that consistently in almost a year.

I hate to say it, but I don’t use webreports very much at all, so I don’t have much to add.

Have you resolved this? If not, I can try to find answers or others to help, but I would definitely recommend filing a PMR about this if it is still unresolved:

Hello Team,

Good Day to everyone.

I am seeing a similar issue as I am unable to export the report into Pdf format… Web report version running on Windows 2012R2 server. I was unable to locate the driver (Xerox phaser 6180 MFP-D PS) on my server but was able to locate Xerox phaser 6180/6189 MFP driver and installed the same.

Do we really need to have recommended driver from bigfix to make this working?? Or why my server is not showing up the driver?? Is there any issue with Windows 2012R2 server itself??

Can someone please help me out here?? Thanks in Advance.


have you tried the steps described in the following support technote?

As described in the above document, if the driver is not initially listed, you have to run the “Windows Update” to get more drivers.
I successfully tested the steps on my Windows 2012 R2 system.

Please excuse me for the delay in response.

Yes I did tried all the steps from the technote as you mentioned above but nothing seems to be working fine.

Tried with windows update as well, nothing is coming up with new updates.

I did opened a support case with IBM, even they have tested successfully on their lab 2012 R2 servers. And I did checked with our platform team, they have confirmed this driver is not supported on 2012 & 2012 R2 servers, the driver is available only on 2008 servers.

So completely blank at the moment as how I can proceed further to fix the problem. Do you think we should raise support ticket with Microsoft? Additionally do you think, Can we download the specific driver and install it manually on the server?

Please let me know your suggestions, Thanks.

Can you please verify if the steps described in the following Xerox document help to complete the driver installation?

Thanks a lot for your response… I will get this checked with my platform support team. I will let you know the updates, thanks again.


I did checked with my platform team, in order to complete the driver installation steps, we need to have the xerox phaser 6180MFP-D PS downloaded from xerox web site, but looks like the driver itself is not available in their site as per the platform team. As mentioned earlier, we are unable to select the drivers automatically, so the platform team has confirmed the only option is to download and install the driver manually on the machine. looks like we can’t do anything at the moment without the files.

Can you please tell me what is the version of OS where you installed the driver? Is that windows 2012 R2 standard or DataCenter version? Because my OS is standard one and the PMR team has tried that on DataCenter only and not on Standard. So I am going to check back with them again and see if they can install the driver on Standard version. Meanwhile Can you please confirm your OS version? Thanks in Advance.

I successfully found and installed the driver on Win2012 R2 Standard edition.


Thanks for confirming. In case if you have the file, Would it be possible for you to send me the printer driver installer please? We are unable to find the driver on xerox website as well, platform team confirmed that there are no issues with server either. Thanks.

I am facing this issue in BigFix Linux Server. Can anyone guide me ?

Check out below link, I’ve resolved this error by following this link. For me, setting the correct DISPLAY variable worked. You should check that once.