UNIX :- Unhandled error: 17NotASignedMessage post agent installation

BESClient service is not starting post agent installation:

  1. When tried to start service, below is the error message
    [root@***********************Logs]# cat 20191018.log
    Current Date: October 18, 2019
    Client version built for RedHat 5 x86_64 running on sysname:Linux release:3.10.0-1062.1.2.el7.x86_64 arch:x86_64
    Current Balance Settings: Use CPU: True Entitlement: 0 WorkIdle: 10 SleepIdle: 480
    Locale: LC_ALL="" LC_CTYPE="" LC_MESSAGES="" LANG="en_US.UTF-8"
    ICU 54.1 init status: SUCCESS
    Agent internal character set: UTF-8
    ICU report character set: UTF-8 - Transcoding Disabled
    ICU fxf character set: UTF-8 - Transcoding Disabled
    ICU local character set: UTF-8 - Transcoding Disabled
    At 06:21:33 -0400 -
    Starting client version
    Unhandled error: 17NotASignedMessage
    Client shutdown (Unexpected error)

  2. Service status :
    BESClient dead but subsys locked

  3. Tried below steps to overcome the issue, but no success.

-. Confirm the BESClient lock file exists in the /var/lock/subsys directory
-. Check to see if the BESClient process is running: $> ps aux | grep -i besclient
-. Kill any besclient processes still hanging around: $> kill -9
-. Check to see if the BESClient lock file is still in the /var/lock/subsys directory. If it is, delete it.
-. Attempt to start the BESClient service again: $> service besclient start

However it is again moved to Deadlock and servers are still aren’t reporting to bigfix.

  1. Restarted endpoint to see for any process concerns to be resolved, but no changes.

Is there any resolution for this issue?

Try to remove and reinstall the agent, also make sure the masthead file (actionsite.afxm) at /etc/opt/BESClient
is not corrupted. You may want to copy it again from the server or from a working client of the same deployment.


I have tried to provide the working mathead file from other endpoint as well as bigfix server and re -install

Still issue is same

You should probably open a support case so the team can check your system. http://support.bigfix.com/

How did you transfer the masthead to the machine? Make sure it doesn’t transfer as text. The line endings cannot change as the file is signed.

1 Like

If the issue is not in the masthead, then I would investigate the way the agent is connected to its parent. Is it direct or thru a proxy or firewall ? The error suggests that the agent is receiving some invalid signed content.

Communication is through firewall, I don’t see any issue from masthead side.

Copied file from bigfix Main server directly.

A good test (if possible) would be to test a direct connection to the parent relay. If the test doesn’t give any relevant result, then please open a support case as suggested by Jason.