Unable to take Remote control session via TRC


I am trying to take a remote control session using the Tivoli Remote control. I am able to login and see all the endpoints, however when I am trying to initiate a remote session, I am getting an error that "Application blocked by Java Security.

I have tried different machine with different java security level and also with exceptions included properly, still no luck with the remote session.

Would appreciate a quick suggestion.


Hi @vipulmeche

Try to update a java policy file with no restriction and replace on this following location, If Java is blocking the TRC session

Default file location:

java.home\lib\security\java.policy (Windows)

Hi Vikki,

Thanks for your input. It seems that something changed in the environment suddenly and it caused this issue.
We got this issue fixed by adding the exception in Java.

Hi Vipul,

This was probably due to the expiration of the code signing signatures in the TRC Controller. I would recommend to upgrade to the latest version (currently 9.1.2 IF0001), as the code signing in the 9.1.2 release was changed to prevent this issue from occurring in the future.
Note that it is recommended to use the Remote Control site in BigFix to keep TRC updated to the latest level, to ensure that the latest security updates have been deployed. You can update to the latest release of TRC even if your BigFix platform itself is an older or newer version, the BigFix platform version number and TRC version number are not synchronized anymore.

1 Like