Unable to PXE boot

I’m trying to set up PXE boot but I’m getting boot device failed. I confirmed that the machine can see the DHCP and the DHCP is talking to the BigFix server but it is not sending a response back. The DHCP and Bigfix server are on different VLANS but are I confirmed they can talk. I can push and capture images. Please see attached screenshot.

Hi, as far as I remember, you should set option 43 in DHCP to point your Bare Metal server (not BigFix server).
Can you check DHCP options here?https://help.hcltechsw.com/bigfix/10.0/lifecycle/Lifecycle/OSD_Users_Guide/c_configuring_DHCP.html

I hope this helps,

1 Like

It is setup to point to the Bare Metal Server. I’m not sure how to set the option 43 ASCII.

Details are this link -> https://help.hcltechsw.com/bigfix/10.0/lifecycle/Lifecycle/OSD_Users_Guide/c_dhcpoption43.html

If I remember correctly, basically you can take the string
and replace the hexadecimal of the pxe boot server ip in the example that is C0:0A:0A:0A with yours

1 Like

Thank you for the help. I added that code along with the one with my IP address and got the new message:

So now it tries to connect to the IP address of the PXE server that has been specified but it cannot contact it.
Is the IP correct? Is it reachable from that computer?

1 Like

I verified the IP is correct and yes it is reachable

Ok, so maybe there’s a firewall running on PXE server computer that is blocking the connection from the target?

1 Like

I disabled the firewall all together but it might be the McAfee so I’m going to disable that and try again.

Tried with McAfee disable still no go.

I suggest to open a case to support team. What I’d try to do is to increase the log level with fixlet 361 “Change Bare Metal server settings” of BigFix OSD site setting the Global Debug Level to Log notice message, then the boot.trc file in the \log folder will report if any attempt of PXE boot reaches it.

1 Like

Figured it out! The WDS was still running and was taking over the TFTP services. Once we disabled it, we were able to PXE. Thank you for all your help!