Unable to execute setup.exe command line through bigfix. Exit code 1


I am having issues with integrating and deploying an application in the client production environment. Each time a deploy action is attempted, it fails with exit code 1 without being able to execute the install command for the setup.exe file.
The application is hardware dependent on Lenovo X1 Yoga and Win 10 OS. It was packaged with a custom .vbs file to fit required production deployment parameters but I’ve tried adding only the setup.exe file in Bigfix with the .exe install command and the result is the same. Not sure at this point where the issue might be. The deployments from our environment are only run with the SYSTEM account on all of the devices.
When manually running the vbs and setup with psexec to simulate the SYSTEM account on the target device, using the exact same command lines , the application will install with no issues. Same goes for an installation using the ADMIN account on the deivce.
I’ve attempted to upload the app files in the Software distribution dashboard both compressed and uncompressed, with a folder or with by adding file by file. File integrity on server appears to be ok.
I’ve set the _BESClient_Download_NormalStageDiskLimitMB parameter on the client to 25000 just to be safe.
I’ve bypassed the OS and Hardware dependency and deployed on several other devices, same issue occurs. Used both wscript and cscript for the cmd line.
The setup file appears to be a standard installshield affair. The application itself also contains drivers

The install log for the app goes like this :

“2017-03-01 13:52:50.830 Log opened. (Time zone: UTC+00:00)
2017-03-01 13:52:50.830 Setup version: Inno Setup version 5.5.5 (u)
2017-03-01 13:52:50.830 Original Setup EXE: C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData\CustomSitexxxxxxxx\xxxxxxx\xxxxxxx (i’ve marked confirdential info with X)
2017-03-01 13:52:50.830 Setup command line: /SL5="$20048,2032494,119296,C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData\CustomSite_xxxxxx__Download\setup.exe” /VERYSILENT /SUPPRESSMSGBOXES /NOCANCEL /NORESTART /LOG="C:\Windows\Logs\xxxxxx.log
2017-03-01 13:52:50.830 Windows version: 6.3.9600 (NT platform: Yes)
2017-03-01 13:52:50.830 64-bit Windows: Yes
2017-03-01 13:52:50.830 Processor architecture: x64
2017-03-01 13:52:50.830 User privileges: Administrative
2017-03-01 13:52:50.830 64-bit install mode: No
2017-03-01 13:52:50.830 Created temporary directory: C:\Windows\TEMP\is-M99EF.tmp
2017-03-01 13:52:50.861 Extracting temporary file: C:\Windows\TEMP\is-M99EF.tmp\PBNUtil.dll
2017-03-01 13:52:50.908 InitializeSetup returned False; aborting.
2017-03-01 13:52:50.908 Got EAbort exception.
2017-03-01 13:52:50.908 Deinitializing Setup.
2017-03-01 13:52:50.908 Log closed. "

Somehow I suspect that either the setup cannot be initialized because it was corrupted when uploading to Bigfix local server or that, for some reason this cannot be run though it.
/SL5="$20048,2032494,119296**, - i’ve not been able to determine the exact source of this

Please advise, if possible, on how to fix this. This is the only application for which I’ve encountered this issue. If I forgot to add details from my testing , I would be happy to provide them.

I wonder whether that might be a clue. As the BigFix client is a 32-bit application, by default it will use the 32-bit versions of “cmd”, “cscript”, and “wscript”. This can be problematic, especially if your application is installing a 64-bit driver.

Your testing with psexec and the SYSTEM account appear to be very thorough, but psexec is not constrained by the 32-bit redirection as the BigFix client is.

Try adding

action uses wow64 redirection false

somewhere in the actionscript before you try to execute the installer.

HI Jason,

Thank you for your input. Unfortunately this did not help with my issue. Same error in the Logfile. I believe the issue can be traced to executing the PBNUtil.dll but not sure how this can be solved at this time. I have also tried re-packaging as an MSI file to try a workaround with unfortunately the same results. By any chance, do you have something else that I can try? Thank you