Two setup.exe process running in taskbar (MsProject installation failed)

Hi Team,

Need assistance I’m trying to install MS Project in GUI mode but unable to install it using below command, whenever installing using runascurretuser.exe getting dual setup.exe instance running in taskbar.

wait cmd.exe /c “C:\swsetup\MSProjectProOnline\RunUtility\RunAsCurrentUser.exe C:\swsetup\MSProjectProOnline\setup.exe /configure C:\swsetup\MSProjectProOnline\Project32Configuration.xml”


due to this getting error


Please share any work around or solution so that I can deploy this with user mode.

Thanks in advance.

I notice you did not include a source path in your xml. Are you pushing all of the install files directly to each client? Seems like that would be a lot of unnecessary workload. I’ve used a similar config to install 365, but I used software distribution to upload the setup.exe and xml file, while the xml file pointed to a server with the rest of the install files

@MMosley, Files already placed in client machines I only want to execute the command and show installation progress, so that if installation interrupt/fail then user can get some error code/msg.

Is it installing correctly when you run the command manually outside of bigfix?

Yes, working outside bigfix.

Hi BigFixers,

Can someone please help me on this?

RunAsCurrentUser.exe is quite old technology, and should be superseded by the ActionScript commands

Action uses wow64 redirection false

Override wait
wait cmd.exe /c "C:\swsetup\MSProjectProOnline\setup.exe /configure C:\swsetup\MSProjectProOnline\Project32Configuration.xml"

Check whether that gives a better result.

@JasonWalker, No luck still facing same issue.

The user may not have administrative rights to install software or there’s something wrong with the method you’re using. I’d follow @MMosley’s advice above and try the SWD Dashboard to deploy.

@JasonWalker,We are placing files well advance in user machine and only want to execute the command via BigFix. Also setup.exe already whitelisted and non-admin user can execute it but still it is not working via BigFix.

Besides that, we tried to run the commands using below action scripts but again no luck same issue happened (two instance of Setup.exe running together)

//1st method
Action uses wow64 redirection false
Override wait
Wait cmd.exe /c “C:\swsetup\MSProjectProOnline\setup.exe /configure C:\swsetup\MSProjectProOnline\Project32Configuration.xml"

//Another method with utility
Wait cmd.exe /c “C:\swsetup\MSProjectProOnline\RunUtility\RunAsCurrentUser.exe C:\swsetup\MSProjectProOnline\setup.exe /configure C:\swsetup\MSProjectProOnline\Project32Configuration.xml"

//Another method tried in VB Scrip
We tried with RunAsCurrentUser.exe utility but no luck (facing issue of two instance of Setup.exe running together) although we checked the script and tried manually it is working as expected only issue is with BigFix.

Have you tested manually running the script as the same user account that’s logged on when running it through BigFix? Maybe something wrong with that user’s profile?
The ActionScript looks correct, and if the user has admin rights and read permission to all of the files & directories involved, I’d have to troubleshoot this as an Office problem, not necessarily a BigFix issue.
I would also at least try the “Manage Software Distribution” method that others on this thread have used successfully.

1 Like

Rather than the wait cmd.exe any other method did you tried like-

Dos C:\swsetup\MSProjectProOnline\setup.exe /configure C:\swsetup\MSProjectProOnline\Project32Configuration.xml


Wait cmd.exe /c cd C:\swsetup\MSProjectProOnline && setup.exe /configure Project32Configuration.xml


Running through batch file, like

Createfile until EOF
Cd C:\swsetup\MSProjectProOnline
setup.exe /configure Project32Configuration.xml

MOVE __createfile install.bat
Wait cmd.exe /c install.bat

You can also use steps with current user settings like in your 1st execution action.

However as @JasonWalker mentioned your steps seems correct but something is not working from os prospective, if your setup is working locally without any special arrangements it should be working without any issue from BigFix.

I have seen many cases where some parameters is required as pre set which sometime missing while running it from BigFix is not looked properly. There could be other conflicts related to access on the machine, pre req of any which might not come in light till now, could be that machine have some os issues etc.

1 Like

You could also try using cmd.exe /k just for troubleshooting purposes. As you would be running this as the user that should keep the CMD prompt that was spawned by the client visible on screen so you can see if there are any anomalies with the syntax of the command line. Sometimes I’ve had to use double double quotes for long filenames though I can’t see your use case would need that, eg

wait cmd.exe /k ""C:\swsetup\MSProjectProOnline\setup.exe" /configure "C:\swsetup\MSProjectProOnline\Project32Configuration.xml""

1 Like