Trying to register a Mac OS X laptop on Bigfix - a lot of issues

Hi all,

during our POC of Bigfix, we already installed many sites and we also connected a few Windows endpoints.
Now, for the first time, we’re trying to connect a Mac with OS X El Capitan.

During the installation of the client, a lot of things go wrong. In fact, after the installation, we can see the BESAgent come live in the “Activity Monitor”. When opening the BESAgent Control Panel, we can also see that the Agent status = Running. We can Stop and Restart the Agent.

But, if we try to run the 'TriggerClientUI", the following error jumps on : “IBM Bigfix Support Center can not be displayed (a needed service is not running)”.

After many hours of surfing and searching on the web, we found out that this was a known issue before V9.2.6 of the agent, but should have been solved in Patch 6. For us, it’s not.

The BESAgent folder is not accessible for looking at the logs. So, I gave rights to the folder to be able to find out at least what is going wrong.

The following is the content of the 20160224.log file under the __BESdata logs folder :

Current Date: February 24, 2016

Client version 9.2.6.94 built for OSX 10.60
i386

Current Balance Settings: Use CPU: True
Entitlement: 0 WorkIdle: 10 SleepIdle: 480

ICU data directory: ‘/Library/Application
Support/BigFix/BES Agent’

ICU init status: SUCCESS

ICU report character set: windows-1252

ICU fxf character set: windows-1252

ICU local character set: UTF-8

ICU transcoding between fxf and local character
sets: ENABLED

ICU transcoding between report and local
character sets: ENABLED

At 13:02:47 +0100 -

Starting client version 9.2.6.94

FIPS mode disabled by default.

Cryptographic module initialized successfully.

Using crypto library libBEScrypto - OpenSSL
1.0.1p-fips 9 Jul 2015

Restricted mode

Beginning Relay Select

At 13:14:36 +0100 -

RegisterOnce: Attempting secure registration
with ‘https://—:52311/cgi-bin/bfenterprise/clientregister.exe?RequestType=RegisterMe&ClientVersion=9.2.6.94&Body=0&SequenceNumber=12&MinRelayVersion=7.1.1.0&CanHandleMVPings=1&Root=http://—%3a52311&AdapterInfo=68-a8-6d-37-64-3c_10.2.13.0%2f24_10.2.13.50_0&AdapterIpv6=68-a8-6d-37-64-3c%5efe80%3a%3a6aa8%3a6dff%3afe37%3a643c%2f64_0’

Registration backing off from SSL, attempting
in clear text

RegisterOnce: GetURL failed - General transport
failure. - winsock error -10 - registration url - http://—:52311/cgi-bin/bfenterprise/clientregister.exe?RequestType=RegisterMe&ClientVersion=9.2.6.94&Body=0&SequenceNumber=12&MinRelayVersion=7.1.1.0&CanHandleMVPings=1&Root=http://—%3a52311&AdapterInfo=68-a8-6d-37-64-3c_10.2.13.0%2f24_10.2.13.50_0&AdapterIpv6=68-a8-6d-37-64-3c%5efe80%3a%3a6aa8%3a6dff%3afe37%3a643c%2f64_0

We already found out that the error -10 is a “err_SOCKET_RECEIVE” error, meaning “A connection was made to the BES Server/BES Relay, but an error occurred when receiving data”.

If I open the link from the log in the browser directly, like http://---:52311/cgi-bin/bfenterprise/clientregister.exe?RequestType=RegisterMe&ClientVersion=9.2.6.94&Body=0&SequenceNumber=12&MinRelayVersion=7.1.1.0&CanHandleMVPings=1&Root=http://HAS-IEM.tobania.local%3a52311&AdapterInfo=68-a8-6d-37-64-3c_10.2.13.0%2f24_10.2.13.50_0&AdapterIpv6=68-a8-6d-37-64-3c%5efe80%3a%3a6aa8%3a6dff%3afe37%3a643c%2f64_, we get the message “Can’t open the page … because the server unexpectedly dropped the connection.”.

The server is running fine for the moment.

What can we be doing wrong ?

Greetings and thanks in advance,

Davy

The issue isn’t on your OS X machine based on your own test but on the server. The server is dropping the connection so I would start looking at server logs.

1 Like

Hi Alan,

just followed the procedure “Best order for startup and shutdown of TEM server Services” after renaming all logs and found out all is starting fine on the server without error messages.

Then tried again on the Mac and still same issue. :frowning:

I can telnet the server without any issue from the Mac by the way.

Greetings,

Davy

Hi all,

done a full server refresh. Checked with server health and all.
All looks ok on server and relay server.
Other connected (Windows 10) PC’s do work fine…

Still can’t get the clientregister.exe to work on the Mac.

Greetings,

Davy

It was due to the Wi-fi network not having access to the server… :frowning: :frowning: :sob:

1 Like

Generally these winsock errors are showing some network state issue so this is the tough part of diagnosing these things.

1 Like