TEM Computer Browser not logging in

A couple of weeks ago I deployed TEM Computer Browser created by @leewei from BigFix labs and it worked like a charm. I updated my account password recently and after that TEM Computer Browser wont log me back in.

Every Time I put in my password, I get the below error:

Any help with this would be really appreciated.


I have not looked at the code, first guess is to clear the browser cookies.
Don’t worry - the password is not stored as readable text in the cookies.

Hey Lee - I tried clearing the cookies and even reinstalling the TEM computer browser but it still gives me the same error message.

There has not been a change in the environment , but I am just curious to know if there is any dependency for the browser to work properly.


Then I suspect your password has a character that the app is not escaping properly.
Can you please try changing the password to something with no symbols?

Hey Lee - I don’t think the problem is with the password - I tried a bunch of combination but the app does not seem to be communicating with the IEM server to authenticate the account.

This is the API URL being posted from the app by which it is not getting what is expected.


If working correctly, we are expecting an XML document with an answer of True
If the username password is not correct, you will get a Web Reports page that says “Invalid username or password”.