Teams Machine-Wide uninstall bat file \ script \ command will not work when run from Big fix

We are trying to Uninstall Microsoft Teams Machine-Wide installer from 64 bit Windows 10 workstations. We have tried msiexec /i and /x with the guid, we have tried powershell using get -wmiobject. We have tried this 10 different ways, every way works when the script \ bat file \ created executable is run local. None of them work when they are deployed as fixlets \ tasks \ via Big fix. All the attempts at using Msiexec.exe fail with error 1605 which is "unknown product. Msiexec.exe runs against the guid and instantly stops. This is a 32 bit app on a 64 bit machine. Best i can guess is the Big fix client is not looking in the wow6432Node location for the guid and it does not think the product is on the machine. Anyone have any similar experiences or ideas on how to get this to work?

Would probably help if you shared the relevance and actionscript code you are using. If you are using code that calls msiexec /x {product-guid} in the actionscript, your probably need to escape the leading { to stop Bigfix using it as relevance substitution.

msiexec /x {{product-guid}

We have tried multiple script configs, and script types. I just tried:

msiexec /x {{guid} /qn

as an action script. it completed with exit code 1605 per Big fix. the product is still installed. I have event ID 1040 (windows installer starts) and 1042(windows installer ends) in the workstation application log for the guid. Both Msiinstaller events at the exact same time down to the second.

The script executes. it just does not complete the uninstall. We have also run the command in the debugger and it works. it is not until we try to send it to a client via Big fix that it fails to remove the product.

When run interactively or through the debugger, you do so in the context of the logged on user.

The Bigfix agent runs in SYSTEM context.

Try using psexec to get a command prompt (or the debugger) running in SYSTEM context and running your uninstall.

We have figured it out. It was not the script or Big fix. There appears to be an some issue with “Microsoft Teams Machine-Wide installer”. Any install that was done locally by a user, cannot be uninstalled by anything running as system. It has to be done by an end user. We have tested scripts via Big fix on end user installs of this software, and system installs of this software. The end users installs fails with 1605. The system installs gets uninstalled by the Big fix deployed script with no issues.

thanks for all the suggestions.

1 Like

Did you end up using the override features in your action to facilitate the “per user” uninstall?