Sylink execution Issue

Hi All,

I have created Sylink package through Software Distribution wizards which contains two XMl file “sylink & sylink Drop command” and one exe “SylinkDrop”.

When I am executing below action script I am getting Exit Code as 11. Action is getting completed but it is not making any changes in endpoint.

prefetch 601624a23e25921efb4ef223162719c54d016e17 sha1:601624a23e25921efb4ef223162719c54d016e17 size:246462 http://xyz:52311/Uploads/601624a23e25921efb4ef223162719c54d016e17/Sep.tmp sha256:0b9e3717db05d0ffc1308f34a5d60763ea2f84171cfe7c5883d48c5fff136be0
extract 601624a23e25921efb4ef223162719c54d016e17
wait __Download\SylinkDrop.exe -silent__Download\sylink.xml

Any help will be highly appreciated.

Hi @Manish

BigFix takes the exit code from the installer, so it’s software related:

I do see that there is no space after -silent and your xml file. Is this not copied correctly or is this in your action script also? That could be the issue maybe?

First try to run the command manually and see if that works. If so, then you can do it with BigFix.

Hope this helps.

1 Like

Thanks steini there was no space between silent and download. Now script is working fine for win 2012 and 2008 but in all the 2003 servers I am getting below error and action is stuck in pending download
ActionLogMessage: (action:5898629) Non-Distributed - DownloadsAvailable
ActionLogMessage: (action:5898629) Action signature verified for Execution
ActionLogMessage: (action:5898629) Cannot empty _Download directory

I got the solution for the empty __Download Dir. Below is the link

1 Like

Hi @steini44,

Above script after giving space is working properly on win 2012 server but on win2008 servers I am getting Exit code 14

Even I stopped BESClient service and removed the BESData and restarted BESClient. After that I have executed the action again for win 2008 server but still issue is same, task is getting 100% completed but with exit code 14 which is not making any changes in endpoint.

Any help will be highly appreciated.

Any input will be highly appreciated :slight_smile:

Symantec’s sylinkdrop is notoriously bad to administrators.

Try giving it a fully-qualified path - like

sylinkdrop.exe -silent "{pathname of download file "sylink.xml"}"

Try running it manually - outside of bigfix.

I have had problems with sylinkdrop failing if a user has the symantec gui open.

I have had problems running it if symantec is doing other operations. Try wrapping it in “smc stop” and “smc start”.

Did you try to remove some files or use another installation path? The error says there is not enough storage? You can also try @JasonWalker method, since I don’t have experience with Sylinkdrop…

1 Like

Thanks Jason and Steini, Above steps fixed the issue :slight_smile:

1 Like

Can you be a little more explicit with this suggestion? I’m using the Stop/Start Service fixlet logic to try to stop and start the “SepMasterService” service, but that doesn’t seem to be working (and I have a feeling that’s not what you meant).

@Manish - Can you share the code that worked for you?

There’s an smc.exe in the Symantec Endpoint Protection folder that can be used to stop and start the Symantec processes. If Tamper Protection is turned on, the Service Controller won’t stop the service. SEP seems to think it’s more secure this way.

Fantastic! Thanks! :smile:

/me goes off excitedly to try it …

Below is the code which I have used for Sylink

prefetch 5ebf12024909e9b3bcbcd0b61ffa0974d1cd788c sha1:5ebf12024909e9b3bcbcd0b61ffa0974d1cd788c size:246440 http://XYZ.DNS.Com:52311/Uploads/5ebf12024909e9b3bcbcd0b61ffa0974d1cd788c/SEPESSA.tmp sha256:c117554aabcc8d70821d38897c855594eec55daf1757233958a7084b327b2e72
extract 5ebf12024909e9b3bcbcd0b61ffa0974d1cd788c
wait __Download\SylinkDrop.exe -silent __Download\sylink.xml

Wow. Really? Hmmm … that’s almost exactly what I’m running with little success. :frowning:

waithidden "{pathname of regapp "smc.exe"}" stop continue if {exists true whose (if true then (exit code of action = 0) else false)} waithidden __Download\sylinkdrop.exe -silent sylink.xml continue if {exists true whose (if true then (exit code of action = 0) else false)} waithidden "{pathname of regapp "smc.exe"}" start continue if {exists true whose (if true then (exit code of action = 0) else false)}
Should wait versus waithidden make a difference?

This command suggests the sylink.xml was constructed in the site? The “successful” one mentioned by @Manish has it in the __Download directory so wondering if that is part of your issue?

The waithidden vs wait should be no different if there is no attempted output or screen display desired

Yeah … I’ve got a big createfile until _end_ section above this that contains the sylink.xml. That part has worked fine, and a previous fixlet (designed exactly like @Manish’s) worked on a small number of machines, but not on most. I know it’s a SylinkDrop issue and not a BigFix issue, but info on SylinkDrop is tough to find. Thanks!

Wondering then if the xml file is somehow making one work vs the other. Remember that the action will be run as Local System. Does anything in the command need to hit a user registry hive? Or needs to look at the 64 bit hive of the registry?

Nope … this is all Local Machine stuff. Check out @JasonWalker’s comment above from Apr 4: SylinkDrop is notoriously finicky. May just have to contact Symantec support and see if I can get any answers there (which I’ll happily share here).