Software deployment for an EXE - Possible issues?

i am trying to test a kaspersky installer which is an exe. I tested this installer locally from cmd. Runs like a charm. The command is something like this:

“ksv.exe” -d c:\temp
If i run it directly from cmd - as a system or as a current user - this runs perfectly showing me the eula next.
When i run it through BigFix - i can clearly see the software running in task manager - but i dont see the eula pop-up - also the cpu usage is 0 - seems like its waiting for my instructions but is stuck.
If i run the exact same action script but remove the -d c:\temp - the eula pops up like a charm.

So it doesnt seem like a priv issue. Anyone has faced something similar?

You cannot get UI when a task is run under a service. In fact this will lock up the task as it attempts unsuccessfully in accessing the UI.

All installs done by the BigFix client must be done in silent mode.

Interesting. However Alan - i do the the Eula Pop up if i dont use any triggers like -d and let the exe run through bigfix without any options.
Will try the silent mode and update.

It worked in silent mode. Thanks Alan.