Setting Internet Explorer Proxy

Hi all,

In everyone opinion, what is the best way to set the proxy for Internet Explorer through Bigfix. I have constructed the following relevance but it always return an error code of -1. When drilling down to the action summary it shows that all steps have been completed. Upon looking on the test machine, the bogus proxy settings I have set to remove are still unchanged. Would anyone be able to point me into the right direction? Thanks.

action uses wow64 redirection false
prefetch ProxyOffreg.tmp sha1:eb3ddbafc4fe9eb17246a87bffd64a00bfdd6f1c size:233 sha256:41e346ec87238e31ae595e25c7b45a47d3db8ae94146807e67b7c3463b87ee80
prefetch RunAsCurrentUser.exe sha1:ee47505ebfb2790b9da8a20ed70e67158e9753d0 size:342528 sha256:1a9b518c775e2a85a7c47801e9b8221df338a65ad8df326485e4cd2aea22fe52
extract ProxyOffreg.tmp
utility __Download\RunAsCurrentUser.exe
waithidden “__Download\RunAsCurrentUser.exe” --w regedit /s “{pathname of client folder of current site & “__Download\ProxyOff.reg”}”

ProxyOff Reg file contents:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]


I use following code for setting proxy on IE & Firefox,

((name of it = “Win2008” or (name of it = “WinVista” and product type of it != nt workstation product type)) of operating system OR name of operating system = “Win2008R2” OR name of operating system = “Win7”) AND (NOT exists value “Proxy” of keys “HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel” of registry)

Action Script:
action uses wow64 redirection true

delete __createfile
delete wizardedit.reg

createfile until @end_create_reg_file
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]

move __createfile wizardedit.reg
waithidden regedit /s “wizardedit.reg”

Thanks & Regards

Hi @vikki

Thanks for your reply. I think I tried using a similar strategy before but I think I may have had the wow64 redirection set to false. I will give this a try and let you know! :slight_smile: