SCA Font Issues

Recently we’ve come across an issue when using SCA within Google Chrome. It must have happened after a patch to Chrome because one day, out of the blue, the font suddenly changed to a much bigger and uglier font. After perusing through the CSS sheets I’ve found the Chrome reads the font “Gill Sans”, the default font within SCA, much differently than other browsers. Removing that font from the scripts and CSS caused the text to default to the other fonts (Calibri, sans serif, etc.)

I don’t know if it has any bearing on why it’s happening but I’ve noticed that the “application.css” file that does, more or less, all of the layout CSS for the pages looks to be calling to a folder for for assistance.


It could be leftovers from a previous version but I figured I’d ask.

I’d prefer not to have to alter the CSS sheets and scripts as I have 0 experience doing so and I don’t want to break it because of such a small cosmetic feature, I also don’t want to have to re-write how SCA functions because of an ugly font.

Anyone else experiencing this issue?

We are aware of the issue, sorry you ran into it.

It cropped up with the newer versions of Chrome (on Windows) when they introduced DirectWrite support, making it so it’ll use the Gill Sans bold font in place of the normal Gill Sans font.

As you mentioned, you could fix it by modifying the CSS and removing Gill Sans from the font-family stack (or disable DirectWrite on Chrome, although that’s a lame fix).

Since it was a bug with Chrome and not SCA, I didn’t want to change anything at first, but if it persists we’ll probably modify the font stack for the next release.

Is there a fix that we could fixletize for the forum or place in I saw this today as well. -Jgo

Certainly would be possible. The manual steps would be approximately as follows:

Replace the following line:

font-family: Gill Sans, Gill Sans MT, Calibri, sans-serif;


font-family: "Gill Sans MT", "Gill Sans", Calibri, sans-serif;

Located in:

TEMA\work\tema\webapp\stylesheets\compiled\application.css (line 875)
TEMA\work\tema\webapp\stylesheets\smoothness\jquery-ui-1.10.2.custom.css (line 787, 797)

I would provide drop-in files but it doesn’t appear that I can attach them to the forum.

Attachments in general seem to be possible in Discourse. It looks like some powerful forum admin just needs to change a setting somewhere:

Tried this theory. I think there is one more. This entry, I believe, constitutes removing them from the script completely.

TEMA\work\tema\webapp\WEB-INF\domains\scm\public\javascripts\scm\renderers.js (Lines 113 and 114)

I also included your changes but the result is still the same. Only after removing them from the CSS altogether did the problem resolve.

You’re correct, missed the renderer.js thing.

I proposed that solution because it worked for me, but I could see how it could fail (if you had “Gill Sans MT” but not “Gill Sans” but did have Gill Sans bold), but it’d be really weird if your machine was in that state (why do you only have the bold font?).

Would you mind checking your Font folder and see which Gill Sans fonts you have installed? Also, ensure you rebooted the server and hard-refreshed to make sure you aren’t being served a cached version.

There are numerous suggestions for changes you can read here:

The most bulletproof would be completely removing Gill Sans from the font stack as you suggested, the downside being anyone not affected by the bug will no longer be able to use Gill Sans, which is something I’d prefer to avoid.

Agreed. Hence the start of the topic to see if the problem wasn’t just me.

So after re-addressing this issue, the solution I found that seems to work without removing the font from the stack is to change the “Gills Sans” font to GillSansRegular in the application.css file as described here: