Runtime Error - pur virtual function call

(imported topic written by rmnetops91)

We just upgraded to v8.0 from and some of our BESClient.exe services on our agents, when starting, throw this error to the end user:

"Microsoft Visual C++ runtime Library

Runtime Error!

Program: C:\Program Files\BigFix Enterprise\BES Client\BESClient.exe


  • pure virtual function call"

Is anyone else running v8.0.584.0 seeing this problem? From what I found on google, it is a programming bug.

The service fails to start. If I manually start the service afterwards, it starts without a problem.

Occurs on Windows XP SP3 machines.

(imported comment written by SystemAdmin)

We see it all the time. It’s been random although we have somewhat narrowed it down to when we are in the Take Action screen and click OK - when the action is being committed to the BES Server it happens.

(imported comment written by rmnetops91)

You see it on the BES Console or at the endpoint agent? These errors are poping up for our users at the endpoints.

(imported comment written by SystemAdmin)

Just the console so far. We are running XP SP3 endpoints as well, so I’ll keep an eye on them now too.

(imported comment written by rmnetops91)

If it was just the console, it wouldn’t be so bad, but we have users calling in left and right. For now they are just clicking past the errors but it’s annoying.

(imported comment written by SystemAdmin)

Is there any way of getting a client log and time of occurrence so we can see what it was trying to do? For the console case, what fixlet are you trying to deploy as an action?

This hasn’t been seen before so it may be very driven by content.

(imported comment written by rmnetops91)

I did send in my client logs and screenshots of the error to support (Case # 00054330). We are trying to collect a minidump for them now, as they couldn’t see anything in the logs.

We have now determined this error occurs on both servers (2003) and workstations. We can’t find the ryme or reason yet though. So far we’ve seen it on 1 server (out of 300) and about 20 workstations (out of 1500). There may be more occurances on servers, but haven’t gotten a chance to check them yet. We also may not be getting reports from end users for all of them (as some users will just click OK past it so they can continue working, and not report it).

(imported comment written by SystemAdmin)

When it happens in the console it’s with all kinds of content. We’ve seen it with the console on Vista and Win7. Seems to happen more if you click off the status windows while the action is being sent to the server.

Event log show these errors:

Faulting application name: BESConsole.exe, version: 8.0.584.0, time stamp: 0x4c5ca0d8

Faulting module name: BESConsole.exe, version: 8.0.584.0, time stamp: 0x4c5ca0d8

Exception code: 0x40000015

Fault offset: 0x00507db7

Faulting process id: 0x115c

Faulting application start time: 0x01cb3e79c754634a

Faulting application path: C:\Program Files (x86)\BigFix Enterprise\BES Console\BESConsole.exe

Faulting module path: C:\Program Files (x86)\BigFix Enterprise\BES Console\BESConsole.exe

Report Id: ccca8ceb-aa79-11df-8665-00059a3c7a00

(imported comment written by rmnetops91)

UPDATE: We were using a task called “BESClientUI is Not Running” that restarts the UI if it’s not running. We think this was causing the crash. When we stopped this action from running, it seemed to clear up the errors on our endpoint agents. We had been using this action from an older version we were on that had an unstable BESClientUI.

(imported comment written by Bill.Ehardt)

Interesting… we see this just popping up on our end as well. This is after about 30-45 mins of an initial install.

Comparing the Eventlog with the BES client log, the last thing to happen is:

At 19:20:44 -0600 - actionsite (http://:52311/cgi-bin/bfgather.exe/actionsite)

Command succeeded setting “_BESClient_ActionManager_UIEnableMode”=“local” on “Fri, 31 Dec 2010 14:52:51 +0000” for client (fixlet 113)

Command succeeded runhidden cmd /C net stop besclient && net start besclient > NUL 2> NUL (fixlet 113)

At 19:20:44 -0600 -

ActionLogMessage: (action 113 ) ending action

At 19:20:44 -0600 - actionsite (http://:52311/cgi-bin/bfgather.exe/actionsite)

Not Relevant - BES Client Setting: BESClientUI Enable Mode (fixlet:113)

At 19:20:44 -0600 -


At 19:20:45 -0600 -

Client shutdown (Service manager stop request)

At 19:20:47 -0600 -

Starting client version 8.0.627.0

FIPS mode disabled by default.

According to the Eventlog, the Service was sent a stop control, the crash happened, then the service stopped, so the restart of the service is causing this on a few servers.

(imported comment written by nberger91)

Any resolution to this, I just had this pop up and crash the master server when deploying a baseline containing this months hotfixes only ?

(imported comment written by nberger91)

I’ve been advised by support this is a known issue (bug # 38832) which no resolution yet. I have tested deploying the same Baselines on the 8.1.551 platform which seems to work okay, however this was with SQL 2005 instead of 2008 which I have running in production.

Can anyone whose exhibited the same issue, confirm what version of SQL they are running, and also any gotcha’s with upgrading to v8.1 db/console so early… ? I suppose my question is, how buggy is 8.1.551 ?

(imported comment written by SystemAdmin)

I can confirm that our issue was resolved with the 8.1 upgrade. But our issue seems slightly different, albeit resulting in the same error message. FWIW, we are running on SQL 2008.

I can honestly say that at this point we have not experienced any new bugs with 8.1 :slight_smile:

(imported comment written by nberger91)

Thanks … 8.1 database and console upgrade fixed the issue :slight_smile:

(imported comment written by awike0191)

We are running 8.1.551.0 with SQL Server 2008 R2. We just started getting this error yesterday after enabling Power Management.

(imported comment written by SystemAdmin)

Running bes client 8.1.551.0 on windows xp and getting Program: C:\Program Files\BigFix Enterprise\BES Client\BESClient.exe R6025 - pure virtual function call"

I see this error when shutting down laptop.

Please advise if how to eliminate this message.

(imported comment written by nathan_m91)

Getting this error as well. Seems random but have recieved it on a number of clients this morning.

8.1.551.0 on Windows XP SP3

Any update on a fix to this?

(imported comment written by MCKELLY91)

Any update on this? We have a few XP laptops BES version 8.1.617.0 getting same error when shutting down. Reinstalling client did not resolve. Thanks.