Running wait run.bat


I have a baseline that deploys a group of standard applications.
Two devices got stuck at Adobe Flash Player at the wait run.bat and the baseline can’t install the remaining apps.
Do you know if I can do something to avoid this kind of situations?
Did anyone encountered this issue?

Andrei Pinzaru

It sounds like you have a single task that installs multiple applications at once using a bat file?

It is better to have separate tasks for each application you are installing so that they can fail / succeed / retry individually.

The apps are not installed by that bat file.
The bat file is automatically created by IEM to report the app as completed failed or other.
This is the part from the action:

Completed // If your package absolutely must interact with the user, replace ‘override wait’ with ‘override run’ and ‘wait’ with ‘run’.
Completed if{name of operating system as lowercase starts with “win”}
Completed override wait
Completed hidden=true
Completed completion=job
Running wait run.bat
                override wait
                wait run.bat

Sorry, I’m not familiar with SWD, so that is why I was confused.

Does Adobe Flash Player install successfully most of the time, but only fail in these 2 cases, or has it never succeeded?

It could be that there is something wrong with the silent install switches being used to install Adobe Flash Player which is causing everything to hang up.

I would try the baselines without Adobe Flash Player for now, and do Flash separately until you find the problem.

How many machines were you able to install successfully on?
What is common between those two machines that failed?

It looks like maybe the installation process got kicked off by the agent but it never completed. So it’s possible that the installer is waiting for input from the user, the installation failed, or many other possibilities.

I would recommend taking a look at the BES agent logs and seeing if there’s any information in those logs that might give you more information on what the issue is.

Also see if you can find the Adobe installation logs and find out if there’s anything peculiar in those logs.


The baseline was completed on 15/18 machines.
Both stuck in running are lenovo tablet 10.

Mostly the installation completes but run.bat is unable to send the status to IEM and remains in Running.

The devices were rebooted with no result and I sent the BES Client service to restart.

I requested the BES Client logs to investigate this issue.

That sounds like run.bat is still running and hung up for some reason. What are the contents of the run.bat that is stuck?

If you install too much in a baseline its possible that some installs may encounter issues (like needing a restart) and others might start needing human input because of that scenario

Its much better to run installs outside of a baseline state because of this to allow each component to check for a restart pending etc.

This may explain why it worked on most but maybe one installer put something like .NET on a machine that didn’t have it and thus the success of the install was different (pending restart or it had an error on the install due to the restart required)

I actually have the exact same issue with pushing a vbscript. Its a single task via IEM and not in a baseline. The job either fails at “wait run.bat” or just hangs until action expiration. Additional thoughts?

When I run into problems like this, my usual debugging steps usually involve something like:

-Is it possible for me to run the vbscript / run.bat manually on the system in question without it hanging?
-Try using the action debugger to see if the action goes that way (i hate running the action via the console and then wondering and waiting if something is happening on the endpoint). If I’m running the action debugger on the endpoint in question with the potentially questionable actionscript, I can more closely monitor the local system like if a new process got spawned.

Hangs until expiration sounds like the item that is being run might be trying to interact with the desktop (bring up a UI of some sort) which you can’t do running as LOCAL SYSTEM. Perhaps under some circumstances what you are trying to do is bringing up an error?

try to change the completion type from job to process
change with: waithidden cmd.exe /c run.bat
Hope this helps!

I know this is an old entry but Thank you!!! it worked for me

1 Like