Roxio 4 Uninstall

(imported topic written by jaxon1234)

Having trouble creating a task to uninstall Roxio Creator Silver 4. Here is the uninstall command needed (from Roxio site and in the registry):

C:\ProgramData\Uninstall{4433FF9E-AF21-4E41-B296-4E13BF4D52F5}\setup.exe /qn /x {4433FF9E-AF21-4E41-B296-4E13BF4D52F5} {lang}=ENU

Here is one that we tried with several modifications and no luck getting it to uninstall through BigFix:

waithidden “C:\ProgramData\Uninstall{4433FF9E-AF21-4E41-B296-4E13BF4D52F5}\setup.exe” /qn /x {4433FF9E-AF21-4E41-B296-4E13BF4D52F5} {lang}=ENU"

Has anyone had any prior experience uninstalling Roxio via BigFix? Thanks in advance!

(imported comment written by BrianPGreen)

Actionscript will interpret text within curly braces as relevance. Since you don’t want that in this case, you need to escape the curly braces by doubling the first brace. For example I suspect the change you need to make is something like:

waithidden C:\ProgramData\Uninstall{{4433FF9E-AF21-4E41-B296-4E13BF4D52F5}\setup.exe /qn /x {{4433FF9E-AF21-4E41-B296-4E13BF4D52F5} {{lang}=ENU

(imported comment written by jaxon1234)

Thank you for the reply Brian. We had tried that version of the action as well with no luck. The action shows as completed, but it does not complete. Today we created two other tasks, one with a batch file and one with a script and we get the same outcome…the action says completed but does not work. When the batch file or script is manually initiated locally on the machines, they uninstall Roxio, so we know the .bat and .vbs files atleast work… Here is an example of the script action:

action uses wow64 redirection {not x64 of operating system}prefetch ROXIO_UNINSTALL.vbs.tmp sha1:a8da8e739257b869998701a2f8643c705c1474e7 size:496 ROXIO_UNINSTALL.vbs.tmpwait "{pathname of system folder & "\cmd.exe"}" /C cscript "C:\Program Files (x86)\BigFix Enterprise\BES Client\__BESData\actionsite\__Download\ROXIO_UNINSTALL.vbs"

After the action says complete even though it has not, if we go to “C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData\actionsite__Download” the ROXIO_UNINSTALL.VBS and VBS.tmp are both there, but they do not run.

(imported comment written by electrix)

Were you able to get this working. I am having a similar issue with trying to uninstall Roxio CD Creator via BigFix. A similar uninstall command works from the computer, but will not execute on via BigFix. Only thing I notice when writing is Bigfix makes the C:\ProgramData directory in the action red font, which is usually not good. Again, I can run the uninstall command just fine either in a batch file or just in the Run command. This shoud be so straight forward to do, but I am probably missing some minor detail. I also tried doing the double curly braces and that had no effect on the fixlet.

Any help will be greatly appreciated.

(imported comment written by jaxon1234)


We ended up and used PStools and a batch file to uninstall the older version of Roxio and then used BigFix to install the new version.