REST API Upload Requires Master Operator Privileges

(imported topic written by hansen_m)

When using the REST API to upload a file to the console I get an error stating that the action requires master operator privileges.

curl -k -u standard_console_user -X POST -F "file=@./test.txt"

Enter host password for user ‘standard_console_user’:

Action requires master operator privileges.

I’d like to be able to use the API to automate the import of Tasks/Fixlets for application deployment and upload the corresponding installer file.

Preferably the API upload account would be a limited access account with access to specific sites with the ability to upload files, and not a master operator. Is there a way to solve this?



(imported comment written by Tim.Rice)

I also wonder why they would limit the API file upload to a MO account. They did something similar with OS Deployment. Strange. They tell us not to use our Master Operator accounts to do deploy content, but then they require that we use them for all these other things.

I can think of a few ways around this problem, without the need to change the API.

Why Upload the file to the Main server via the API?

  • Rather, place the file on another http server and use the ‘DOWNLOAD’ command to reference it. The Server will then Happily download the file and place it in it’s cache whenever it’s needed.
  • Treat the files the same way that JAVA updates are handled. Manually cache them on the server.

I recommend you explore the first option. I’m not comfortable with the way JAVA updates are handled anyway. I don’t like having to perform Manual steps in what is otherwise an Automated process. Too much risk of a mistake.

(imported comment written by dominic.otoole)


I think this post should be redirected to the
TEM Deployment and Configuration forum.


(imported comment written by hansen_m)

Thanks, reposted in Deployment and Configuration.

Also, the RFE is located here -