Require Assistance Installing Cognos Planning 8.4

(imported topic written by gumbinator91)

Install Cognos Planning 8.4. Require assistance. I cannot get the install to work because the files are actually extracted from a zip folder directory (only some of the install). The install only partially installs, and chokes on this part. I have tried running the normal install from the _Download area in bigfix client. I have tried xcopying the install folders that contain files and nested folders etc to the C:\temp directory on the machines, and running a batch file to install the app using a command line: C:\TEMP\Cognos_Planning_8\win32\issetup.exe -s response.ats. (“blah” being the long folder names I am dealing with). (Running XPSP3 in this computer environment). Bigfix or me seem to be unable to fully install the app that installs fine run directly on the pc in question using batch etc commands.

(imported comment written by BenKus)

Hey gumbinator,

It seems that what you want to do is straight-forward… Can you post your actionscript so we can see if there are any issues?

Alternately, this may be a problem with the installer running as the SYSTEM account… can you try to manually run the installer from the SYSTEM account using instructions here:


(imported comment written by gumbinator91)

Well I’ve tried so many. And the install actually partially runs but misses items like placing the app in add/remove programs. It also does not install the files contained inside the subfolder called “zip.”

Here is my latest… (I also ran the script to install directly from the __Download folder. It resulted in exactly same install issues. Note: There is the main folder, but also files and folders inside it (Cognos). It is the install that only partially completes no matter which approach I used.)

download http://bigfix.bcferries.corp:52311/Uploads/0d96dfefe0146c2d1d6c87321aa3e83862bff3d1/InstallFiles.tmp

continue if {(size of it = 245401488 AND sha1 of it = “0d96dfefe0146c2d1d6c87321aa3e83862bff3d1”) of file “InstallFiles.tmp” of folder “__Download”}

extract InstallFiles.tmp

DOS copy “__Download\uninst.ini” “C:\Program Files\Common Files\Cognos Shared\cer4\Uninstall\uninst.ini”

waithidden “C:\Program Files\Common Files\Cognos Shared\cer4\Uninstall\uninst.exe” -u -s “C:\Program Files\Common Files\Cognos Shared\cer4\Uninstall\uninst.ini”

waithidden MsiExec.exe /X{{0EAE6D6C-6621-4C80-A529-24D5049F8100} /qn

DOS copy “__Download\install.bat” “C:\Temp”

DOS MD C:\TEMP\Planning_Client_8.4

DOS MD C:\TEMP\C8_Plan_Client_8_4_Win32_FP001

DOS xcopy /S /E /Y “__Download\Planning_Client_8.4*.*” “C:\TEMP\Planning_Client_8.4”

DOS xcopy /S /E /Y “__Download\C8_Plan_Client_8_4_Win32_FP001*.*” “C:\Temp\C8_Plan_Client_8_4_Win32_FP001”

waithidden C:\Temp\install.bat

// waithidden “{pathname of system folder & “\cmd.exe”}” /Q /C “{(pathname of client folder of current site) & “__Download\install.bat”}”

(imported comment written by BenKus)

Hmm… I don’t see anything obviously wrong… If you try to manually run the installer from the SYSTEM account from the temp folder, does it have the same broken install behavior (I am trying to see if the account that runs the installer is the issue or if there is something wrong with the way we run the installer)?


(imported comment written by SystemAdmin)


I actually have used BigFix to roll out the Cognos Planning 8.3 client. It sounds like you already have the important stuff like creating the response file out of the way. The installer needs to keep the same folder structure or it will not work. I had some trouble getting the installer to execute from the subdirectory of the “__Download” folder, so I cheated a bit with an AutoIt script:

Exit RunWait(@ScriptDir & “\win32\issetup.exe -s silent.ats”, @ScriptDir & “\win32”)

If you haven’t checked out AutoIt, it is a simple, yet very powerful scripting language. I just compiled it into an EXE named “install” and included it the Planning client Zip in the root, that way it ends up in the “__Download” folder. From there I just did a "waithidden “__Download/install.exe” and it worked.

I can’t remember the specific reasons why I couldn’t get it to work without the AutoIt script, but it worked like a champ after I did that.

(imported comment written by gumbinator91)

Thank you for this information. I am unsure if I understand this precisely at this moment, but I do get the gist. I will work from this angle. I will let you know what I’ve done. Thanks again.