Remote console on Bigfix9.5

Need to setup Bigfix Remote console, I can see documents for 9.2 and my current version is 9.5

Need support on how to setup the remote console and how to take a console of VM’s.

have you tried opening a case. I think they can help you with that. I need to do this as well./ Plus I think remote control has a 9.1v

I tried installing the targets but after installing the target . How do we take remote console fo the servers what are the options ?

Opened a case and working with them too

Hi ptonni,

This is what documentation is made for:

The Controller and Target user guides are a good starting point.


1 Like

I have raised a ticket with technical team and was able to resolve the windows remote console issue … But unable to install targets on linux servers.

Have you tried manually or through the BigFix Console ?
What is the output / return code ?

The installation usually fails on Linux because of missing dependent rpm packages.
Have you tried to install the packages reported here ?

I tried from bigfix console … Do we have packages for x64 ?
As per the document says its i386,it would be helpful if you can share the document for x64

No unfortunately only i386 binaries are shipped for the native components (Target, Broker, Gateway and CLI). Maybe they will be added in future.

Anyway you shouldn’t have any problem if you install those packages in a x86_64 machine.
RedHat or CentOS can handle multiple architecture binaries and related libraries. You just need to configure the DVD as repository or add the online repositories.

I tried but the per to per target installation is failing on client machine.
At 10:06:46 -0400 - actionsite (http://BFXServer:52311/cgi-bin/bfgather.exe/actionsite)
Command succeeded (Exit Code=1) wait rpm -U __Download/ibm-trc-target-9.1.4.i386.rpm (action:168)
Command succeeded parameter “ExitCode” = “1” (action:168)
Command started - wait /bin/sh -c "echo “ERROR: Target was not properly installed. ExitCode=1 " >> …/rc_fixlet.log 2>&1” (action:168)
Command succeeded (Exit Code=0) wait /bin/sh -c "echo “ERROR: Target was not properly installed. ExitCode=1 " >> …/rc_fixlet.log 2>&1” (action:168)
Command succeeded (1) exit {parameter “ExitCode”} (action:168)

Let’s try this:

  1. Select the Target installation Task then click on Copy to create a custom copy.
  2. Select the Actions tab and modify the Action script like this:
  • remove all the content after
    wait rpm -U __Download/ibm-trc-target-9.1.4.i386.rpm
  • add the following line:
    copy “__Download/ibm-trc-target-9.1.4.i386.rpm” “/root/Downloads/ibm-trc-target-9.1.4.i386.rpm”
  1. Run the custom Task just created. The rpm will be saved in the folder /root/Downloads
  2. Run manually the command using bash (rpm -U /root/Downloads/ibm-trc-target-9.1.4.i386.rpm) and see the specific error reported.

I hope this will help.

I tried that

[root@prodimpact /]# locate ibm-trc
/var/opt/BESClient/__BESData/Tivoli Remote Control/__Download/ibm-trc-cli-9.1.4.i386.rpm
[root@prodimpact /]# cd /var/opt/BESClient/__BESData/Tivoli\ Remote\ Control/__Download/
[root@prodimpact __Download]# ls
ibm-trc-cli-9.1.4.i386.rpm trc_cli_linux_9.1.4_0406.bfa
[root@prodimpact __Download]# rpm -ivh ibm-trc-cli-9.1.4.i386.rpm
error: Failed dependencies: is needed by ibm-trc-cli-9.1.4-0406.i386
[root@prodimpact __Download]#

I think we need to download the required packages libgcc, libXmu, libXtst, libXp, libXi, libXScrnSaver, and libXinerama in 32bit and then try .

I thought that you already installed the dependencies.
You definitively need those packages.
For that specific error you need the package libblkid.i686
I don’t know if this is already installed as a prerequisite for another listed package.
In order to install the 32 bit version of the packages you can just add .i686 to the package name

Let us know,

I tried installing manually with the required depencies and it got installed …

root@vamsirhel73 Logs]# rpm -qa |grep -i ibm-trc-target
[root@vamsirhel73 Logs]#

And tried to reinstate the installation from the console and now it gives me an different error “Not Relevant” , But the package is installed on the server .Now how do i take console of the server ?

Hi ptonni,

Since you already installed the package the task is reported as “Not Relevant”.
You should see as relevant the task “Uninstall IBM BigFix Remote Control Target for Linux” instead.

If you uninstall the target and reinstall it using the console you shouldn’t have any problem now.

Now how do i take console of the server ?

What server are you referring to ? Do you mean the machine where the target has been installed ? Or are you referring to the Remote Control server ? What do you mean with “console” ?

I meant the target machine … I tried to take console from the Remote control server its giving me an java error
[root@BFXServer ~]# java jar /opt/ibm/trc/controller/TRCConsole.jar
Error: Could not find or load main class jar
[root@BFXServer ~]#

I don’t know why the documentation reports the command that you used.
Anyway in order to start the controller on Linux you should use this:


Or you can use the entry in the Desktop Environment menu:

I tried and unable to find the option

[root@BFXServer ~]# rpm -qa |grep BES
[root@BFXServer ~]# rpm -qa |grep IBM
[root@BFXServer ~]# rpm -qa |grep -i IBM
[root@BFXServer ~]#

[root@BFXServer ~]# /opt/ibm/trc/controller/
-bash: /opt/ibm/trc/controller/ No such file or directory
[root@BFXServer ~]# uname -a
Linux BFXServer 2.6.32-358.el6.x86_64 #1 SMP Tue Jan 29 11:47:41 EST 2013 x86_64 x86_64 x86_64 GNU/Linux
[root@BFXServer ~]#

That’s because you installed only the JRE used by the Controller and not the Controller itself.
You need:

  • ibm-trc-controller-jre-9.1.4-0406.i386.rpm
  • ibm-trc-controller-9.1.4-0406.noarch.rpm

If you use the "Deploy IBM BigFix Remote Control Controller for Linux"
fixlet in the BigFix Console, you will have both packages installed automatically.

Thanks … it worked I think we are close to complete .

[root@BFXServer controller]# ./
Exception in thread “main” java.lang.UnsatisfiedLinkError: /opt/ibm/trc/controller/jre/lib/i386/ ( cannot open shared object file: No such file or directory)
at java.lang.ClassLoader.loadLibraryWithPath(
at java.lang.System.load(
at java.lang.ClassLoader.loadLibraryWithPath(Native Method)
at java.lang.ClassLoader.loadLibraryWithPath(
at java.lang.ClassLoader.loadLibraryWithClassLoader(
at java.lang.System.loadLibrary(
at java.awt.Toolkit$
at java.awt.Toolkit$
at java.awt.Toolkit.loadLibraries(
at java.awt.Toolkit.(
at java.awt.Component.(
at Source)
at Source)
[root@BFXServer controller]#

Tried to open from the GUI too, I believe we need to set the library path

No problem,

You need to install libXtst.i686 which is missing in your environment.
Maybe it should be reported as a requirement in the relative page.