Program Install Not showing up in Add/Remove programs

I have a software deployment that completes, the directory is there, the service is installed and running but if you look at add remove programs it does not show up. I found one article below but this does not pertain as the characters in the Registry are under 60 for the name. Has anyone ever run into this issue? If I install it with the same parameters locally it will be in the add/remove programs of the control panel. The action is pretty simple:

prefetch be6c9b211e321e84d52f504d9154e606bad2f295 sha1:be6c9b211e321e84d52f504d9154e606bad2f295 size:22348586 http://BDOWSPBGFX:52311/Uploads/be6c9b211e321e84d52f504d9154e606bad2f295/insight-agent.tmp sha256:741151557a444d796f576ac7abe4e04177ae76619d4e77448d17aad13a4e1ee4
extract be6c9b211e321e84d52f504d9154e606bad2f295

_wait “{pathname of system folder & “\msiexec.exe”}” /i "{(pathname of client folder of current site) & "_Download\agentInstaller-x86_64.msi"}" CUSTOMCONFIGPATH=c:\windows\temp /qn

I have tried it with no custom path also and get the same results

[Program Is Not Listed in Add/Remove Programs After Installation]

I’ve heard of this happening with custom created MSI files.

What happens if you install the application manually?

To be clear, this doesn’t sound like a “BigFix” problem, more like a problem with the MSI itself.

1 Like

I agree with @TimRice that this looks like an MSI issue.

If you install the MSI by hand (not using BigFix) does this symptom persist?

More info on how MSI lays down it’s Add Remove Programs (ARP) entries here:

I’ve recently (a few months back) heard from one of our desktop support folks of a software package installer that when they install it MANUALLY, it works OK, but when installed via BigFix (ala the SYSTEM account) it installs but does not put the Uninstall registry keys in properly.

They were going to work with the vendor to figure out what was going on. My suggestion if they come back to be without a resolution is to simply have the BigFix Task/Fixlet create the Uninstall Key manualy until the Vendor can figure out what is happening.

I’ve created MSI’s of my own in the past and have never actually seen this happen like this before.

I’ve seen cases where the MSI populates the per-user uninstall key (under the SYSTEM account’s HKCU\Software hive, so it’s not visible in Add/Remove Programs for any real user account) rather then the per-system key.

Usually we can avoid that by adding the ALLUSERS=1 parameter on the msiexec command line.

I am facing similar issue with an exe. When i run the EXE manually, it’s entry is created in programs and features but not after the push from Bigfix.