Problem with fetching AIX patches and Manage Download Plug-ins Dashboard

When trying to run the Patch For AIX task ID 337 AIX: Update for oppenssh (, I got error ““HTTP Error 1: Unsupported protocol: Protocol AIXProtocolR2 not supported or disabled in libcurl””

So after some google I found someone posted solution to enable the Patching Support and under the “Download Plug-Ins” when I clicked on the BES server, I get an pop up error message “An internal error has occurred. To ensure the dashboard continues to function properly you may need to close and reopen it.
Details- Error #1010

I tried to re-install the Flash Player to older version 11 and also the latest version 30 but no luck. I tried to clear the BES Console cache and restart BES console and still no luck. Any help would be appreciated.

My BES Console is on Windows7 and BES Server is Linux-based .

1 Like

For installing Flash, it’s the Internet Explorer ActiveX version, so make sure you’re actually installing that. You should restart the BES Console just to be sure because sometimes closing the dashboard doesn’t actually close it and when reopen you’re just opening from the same session.

The issue should only affect the BES Console machine and not dependent on the BES Server.

1 Like

Thanks for your reply Evan. I took your advice and reinstall the Flash for Internet Explorer Active X version, but still I’m getting the same error after restarting the console. I also verified the flash is loaded in the BES Console with the latest version 30.

On a sidenote, I realize that my “Encryption Analysis for Clients” is having zero applicable computer count. Would it be a problem for the “Manage Download Plug-ins”?

That’s definitely a possibility. For the dashboard to function properly, you must satisfy some prerequisites:

  • Run the Fixlet “Enable Encryption for Clients” from the BES Support site
  • Activate the analysis “Encryption Analysis for Clients” from the BES Support site
  • Activate the analysis “Download Plug-in Versions” from the Patching Support site

Normally, there will be a prompt letting you know of these prerequisites but sometimes, users manage to hide the prompt.

Make sure you run that Fixlet and activate the Analyses on the endpoint that will receive the plugin.

I found the “Enable Encryption for Clients” Fixlet but it was greyed out and the applicable computer count is zero. How do I fix that?

I try to run “Enable Encryption Clients” and I see no clients are applicable. Screenshot as follow:

When I look at the relevance it has “name of operating system starts with “Win””. Does that mean the Fixlet can only be applied to Windows BES Client?

All my clients are running on linux/unix platforms, I wonder if that’s the reason I can’t see any applicable clients.

The AIXProtocolR2 error would indicate that the AIX Download PlugIn v2 isn’t configured properly. As indicated above, you’ll have to resolve the Flash Player for Internet Explorer dependency so that you can access the Manage Download Plugins Dashboard. For additional details, you can check the Download Plugin logs under /var/opt/BESServer folder path.

You’re right. I forgot that the encryption task and analysis only applies to Windows. Regardless, the analysis still needs to be activated.

As for the dashboard error, I don’t know what else can be done. You’re the first to report a problem with it and we haven’t modified the dashboard in a long time. Have you validated in IE that you can access Flash content just fine? If not, it’s possible that’s why the dashboard isn’t working properly either.

Thank you all for your help. I’ve been trying for a few days to resolve the issue but didn’t make any progress.

I realized the Encryption needs to be enabled and found this page to generate and enable encryption key on the Linux based BigFix server. Now the BES server reports encryption is in ENABLED state but the error in dashboard persist.
[root@server bin]# ./ -reportencryption -status
Available options:
-rotatekey -privateKeySize=<min|max> [-deploynow=yes | -deploynow=no -outkeypath=] -sitePvkLocation=<path+license.pvk> [ -sitePvkPassword= ]
-disable -sitePvkLocation=<path+license.pvk> [ -sitePvkPassword= ]
Usage: -reportencryption [options]

I also upgraded my BES Server/Console/Client from 9.2.6 to 9.5.6, doesn’t help.

I tried a different version of Flash Player for ActiveX at 11/12/30, on Windows7 and Windows Server 2012, same error. I wish there is a linux based console.

I tried to open the “Fixlet Maker” dashboard right above the “Manage Download Plug-ins” which also runs on Flash, it works without any issue. This led me to believe problem may not relate to Flash Player.

I revisited the “Manage Download Plug-ins” dashboard and realize the Plug-ins windows are minimized by default. I expand it and there is no plugins shown until I clicked on the server name. Then I’ll see just the AIX Plugin listed followed by the dashboard error “An internal error has occurred”.

I try to find any Download Plugin related logs on the BES server but can’t even find the AIX Protocol directory. Seems like the plug-ins is not even downloaded.

[root@server BESServer]# ls -l /var/opt/BESServer/DownloadPlugins
total 0
drwx------. 3 root root 61 Jun 26 19:28 SWDProtocol
[root@server BESServer]#

Opened a PMR but didn’t get any update for a week. This Tivoli stuff is really getting the better of me. Only thing that I haven’t tried is to move BES Server to window platform.

You won’t have any files related to the AIX Plug-In until you get the Plug-in registered (which is what this dashboard is supposed to do for you).

Sorry I can’t help any more than that, you’ll probably need to continue working it through your PMR, but just so you know you shouldn’t find traces of the plug-in on the filesystem yet.

1 Like

I already activated the “Download Plug-in Versions” analysis from the Patching Support Site, and was thinking it will download the plug-in for me. If it isn’t for that purpose then what is actually happening once I activated it?

Analyses don’t take any actions. What this Analysis likely does is report the versions and configuration information for any Download Plug-Ins that are installed in your environment. This data is probably retrieved and used by the Dashboard, so the Dashboard would depend on this Analysis being activated and the results reported up.

For reference, when the dashboard works, it should look something like this…

When we select a plugin the “Register” button activates and allows us to register (install & configure) the plugin, giving this pop-up in the case of the AIX plugin


When we “Ok” that, it creates an Action that we can target at the root server or relays to install the plugin -

This Action is what creates the files & folders associated with the plugin_AIXProtocol plugin.

Maybe related - do you have your computers, at least the Root Server, subscribed to the “Patching Support” site? If you’ve activated the Analysis, but the root server is not subscribed, you won’t get the results to populate that dashboard.

1 Like

Step #1:

Step #2: Wait

Step #3: There are two new analysis. You can activate these in advance, OR wait for the new dashboard to load. Once it is loaded the menu will change and you will see this>


If you have not started the analysis / you should see a message that there are two analysis that need to be started. Click on them if they are there.

This is the key analysis - when working with a Linux Server:

The encryption needs to be “clicked on” - and it does download some files - but, afaik, remains invisible.

Now: when wanting to use the AIX plugins (note plural) - activate them both!

I made the mistake of only activating the R2 plugin - and I got an error message in the Action Summary saying/hinting the AIXplugin was not functioning (as it was not registered!).

Hope this helps!

p.s. - to try an undo everything I believe you can deactivate the analysis, and maybe run the new task/fixlet:

1 Like

I try to remove the Patching Support and then re-enable (with all computer subscribed). Then I also run the Uninstall BES Server Plugin Service Fixlet and then re-install it. However, I cannot see any new analysis showing up under the Patching Support nor BES Support Site. Can you tell me what are they?

Then when I open up the “Manage Download Plug-ins” I can see a message saying one of the two analysis not being activated as follow

Then when I click on the “Encryption Analysis for Clients” it shows it is already activated although the applicable computer shows 0 since the BES server is running on Linux but the relevance refers to windows machine.

Then I go to activate the “Download Plug-in Versions” in the Patching Support Analysis. When I re-open the “Manage Download Plug-ins” dashboard the 2 analysis will be cleared and I see the BES server listed. If I click on the server name I’ll get the error again.

I think my problem may be caused by the “Encryption Analysis for Clients” shown as Activated despite there is no applicable computers listed, so the Manage Download Plug-ins dashboard would crash.

If i try to deactivate the “Encryption Analysis for clients” and then open the Manage Download Plug-ins dashboard, I’ll see the message that one of the 2 analysis is not activated again.

Is running BES Server on Windows my only solution?

I don’t think so. There are plenty of Linux BES Server users and you’re the first to report an issue. The dashboard hasn’t been modified for almost a year now, so most likely there’s something different about your deployment compared to others.

In the dashboard itself, after you click the “close” button, try hitting Ctrl+Alt+Shift+D. It should bring up a popup inside the dashboard with buttons to view the log and a slider for log levels. If viewing the logs doesn’t seem to reveal anything, adjust the slider the one that gives the most logs and refresh the dashboard (Ctrl+F5), then do Ctrl+Alt+Shift+D again. See if there are logs this time that will reveal what’s going on.

I just setup two POC, both on Linux RHEL, one that was an “upgrade” from an ILMT server, and one from scratch.

Both of these also show the encryption with 0 subscribed computers. I expect the dialog is not looking at the number of end-points subscribed - instead, merely that they are both activated.

If you have just started, as ‘boring’ as it is, on one hand, yet clearly a learning experience! Install it all again. Ideally, you can have a second RHEL VM and just copy the masthead, and the certificates to the new server, and try it again.

I assume SELinux is still off. Try stopping WebReports and WebUI (on a sandbox I built on Centos I was running out of files I could open) - not that you should need to, but maybe it gets you moving forward.

And, if still not working - rather than just trying to reload the dialog:
a) close the console
b) restart BES (and/or reboot the Linux server))

In any case, I have set this up MANY times, and the “Manage Plugin” dashboard has always - just worked.

HtH, Michael

Thanks everyone for your help.

I switch the BES Server from Centos7 to Redhat7 and install the BES server from scratch. That seems to resolve my Manage Download Plug-ins Dashboard issue. Not sure if the BESServer doesn’t want to play on Centos or if there were any files corrupted before, but bottom line a fresh install did the trick.

Maybe one day I might switch back from Redhat to Centos and see what happens.


I think CentOS is not officially supported as a root server, but I’ve heard rumor that can be worked-around by editing /etc/redhat-release to make it look like a RHEL server, making it relevant to some of the required fixlets. Your Mileage May Vary.

1 Like

@JasonWalker is correct that CentOS is not supported for the root BES server, only BESRelays.

I can confirm - that for a sandbox it seems to be fine - I change the centos-release file. And to patch the centos server, I reset the centos-release back to original, do an online update, gather the centos site, and check for ‘terrible’ things. As centos does not need a plugin, I can also run fixlets to patch extra things, should I so choose - and then switch centos-release back to looking like RHEL. FYI: I use the ‘warning’ from the RHEL site (when I have it turned on) to decide if I need to patch CENTOS.

In short, I fake this info for the plugins, but manage it as CENTOS. My mileage has been good!

[root@t430 etc]# ls -l release
-rw-r–r-- 1 root root 44 May 24 22:01 centos-release
-rw-r–r–. 1 root root 38 Nov 29 2016 centos-release.orig

lrwxrwxrwx. 1 root root 14 May 22 16:45 redhat-release → centos-release
lrwxrwxrwx. 1 root root 14 May 22 16:45 system-release → centos-release

1 Like