Problem issuing a command with quotation marks

Hello everybody,

I’m trying to distribute a vmware horizon client silently with bigfix but the thing is that the command has quotation marks. This is the command:

VMware-Horizon-Client-x86_64-4.2.0-4336726.exe /S /V"/qn DESKTOP_SHORTCUT=0 VDM_SERVER=xxxx REBOOT=Reallysuppress"

I have tried changing the quotation marks for %22 (I have read in another thread), but it still continues doing the same, it doesn’t fail, it gives a not reported status, but it does nothing. I’m doing through manage software distribution dashboard but not guessing how to do it.

Any idea are welcome.


%22 is really only needed for relevance. In the actionscript, it should be able to handle quotation marks just fine (I’ve done it before). Might be helpful if you can tell us what is the error specifically and provide us with at least a snippet of what it looks like in the actionscript.

Without knowing anything about your executable, are you sure it’s “/S /V” (upper case) and not “/s /v” (lower case). Another thing to test is if your executable can only run in the local user context rather than the system user context. Additionally, did you test it out manually yourself in the command prompt?

Hello Zevanty,

Thanks for clarifying the %22 issue.

The command was taken from vmware kb and it’s ok performing it locally.

The issue has been solved since there was a problem with the bigfix clients (I have tested in 2 pcs and both of them were in an unwanted situation).

Thanks for the help.

Like you’ve said, the quotation marks work normally, there is no need to transform it.