Platform API - Requirement Failure @ DataSerializeBoost.h:104

(imported topic written by SystemAdmin)


I’m currently trying to develop a custom application that will import content into TEM 8.2 to deploy to our machines using the Platform API.

I’m trying to connect to our TEM server to import an XML and I am receiving the following error:

Unexpected server error: Requirement failure at DataSerializeBoost.h:104 ( which < boost::mpl::size::value ) (error HTTP 500 in method /data/import)

Just to validate that its not my code, I ran the BESImportFile-1.2.exe tool and it is receiving the same error. I also tried multiple .bes files

(imported comment written by SystemAdmin)

Hi Casey,

Have you confirmed that the .bes files you’re using are valid? A good way to test this would be to attempt to import the file(s) using the file->import option in the Console. Another good test is to export a fixlet from BES Support to a (definitely valid) .bes file and then try to import it using the BESImportFile-1.2 executable. If both of those tests succeed, it would seem that your .bes files are malformed. If either fails then there is another issue in play. I performed both operations successfully on an 8.2.1175 deployment, which exact 8.2 version are you using?



Austin McGee

Software Engineer, IBM TEM Platform

(imported comment written by SystemAdmin)

Austin -

I have a few questions/comments that might help us out a little.

First, should the import exe file be ran from the server in which we installed the API on? or can we run it from any machine? could there be a conflict accessing the API from a 32 bit machine when its running on a 64 bit machine?

(imported comment written by SystemAdmin)

I tried both actions you have a suggested. Importing through the console works fine but trying with the API still fails regardless of the .bes file. I believe we are using 8.2.1093

We have 2 big fix environments and they are both giving me the same error.