OSD Touchpad - Hardware Compatibility

Hello all,

I am currently in the process of simplifying the imaging process for our IT technicians. Part of this involves making the BigFix imaging process more user friendly by offering techs a working touchpad in the WinPE environment (while they can just plug in an external mouse or tab through the menu, wired mice are not always going to be available for them, and the selected menu item is very difficult to see when tabbing through the deployment menu).

The issue is that most of our newer models (HP 640 G10) don’t have a working touchpad while the older models do. I have tried various things to resolve this:

  1. Uploading drivers and binding them to our G10s through the BigFix console.
  2. Manually loading Serial IO and related drivers in WinPE cmd with “drvload” and “net start” commands.
  3. Uploading updated MDT bundles containing HP driverpacks to BigFix and PXE booting with those.

None of the above have worked and I feel like I’m running out of options here. Any help, guidance, or correction would be greatly appreciated. I am fairly new to BigFix and OSD in general so maybe there is something simple that I missed or can/should be doing differently.

Many thanks to anyone willing to help or offer insight on this challenge!

It may require a driver for the port to which the touchpads are attached (i.e. a chipset, USB, or PCI driver for a parent device).

On a working laptop that’s already been installed, check Device Manager, change the view to “By Connection”, find the touchpad device, and show what parent connections it has.

Then you’ll want to find those drivers and test loading them manually in WinPE. If that works, you can add them to your driver library and maybe add bindings if necessary

Makes sense. I’ll give that a go and keep you posted on the results.

Jason, you are the best! I followed the touchpad driver up the parent/child driver chain and came across an Intel Serial IO driver named " iaLPSS2_I2C_ADL" that was nowhere to be found in the winPE environment. Using HPIA, we were able to upload said driver and bind it to the G10s, thus resolving the issue.

Thank you!

1 Like

Great to hear! Glad to be able to help.