OS Deployment Driver Problem


I’m trying to deploy couple of ISO images (Win 7, Win 2008 R2, Win 2012 R2) to some bare metal targets but they are keep on failing after loading the boot.wim showing a blue screen telling srvinfo.sys failed .

This is the screenshot of the error:

When I checked the driver bindings, it turned out to be a critical driver is missing and I guess that might be causing the problem. I tried searching for the driver on internet but unable to find.
If anyone has gone through above error and have the driver, that can you please share me cause I badly need the driver.

below is the driver name:
VMware SATA AHCI Controller (15AD.07E0.15AD.07E0)

Below is the screenshot of my Driver binding:


Hi @JasonWalker , can you please suggest something which might help me here to get rid of this issue.

it could be that your winpe deployment engine is corrupted. Could you please try to run a full sync on the bare metal server and retry?

@sergio_tarchi, I have tried full sync multiple times on bare metal server and that didn’t help really.

Does it occur when booting from different bare metal servers and on all target models or only some bare metal servers/models?
If only some models have the error, which are these models?

I have only one bare metal server and it fails for all targets of different model i.e. Windows 7 x64, WIndows 2008 R2 x64 and Windows 2012 R2 x64.

I mean different hardware models. If it occurs on all target models and you already tried to full sync, I suggest to try to import again the MDT bundle, selecting the option to overwrite the pre-installation environment, to see if it could be due to a corrupted WinPE.

Let me check that way if it might help.


The easiest way to obtain the VMWare drivers is to run the VMWare Tools installation on one of the virtual machines. Once the tools are installed, you can retrieve the drivers from where they are extracted under \Program Files\VMWare Tools, and then upload those drivers into your OSD dashboard.

Be sure to bind the drivers to both the OS you are deploying, and to the Windows PE versions that you are using during the deployment; and then regenerate your WinPE resources so the updated driver is included.

Hi @JasonWalker, did exactly as per your suggestion but no exact driver is available at the time of binding with OS or WinPE resources.

Can you please suggest any other procedure which might help to resolve this issue?


I am having the exact same issue. My vmware SATA driver is now missing. This was working earlier in my environment i am thinking updating VM workstation caused the issue. Anyone else having success finding the missing driver?

which is the issue? Bluescreen on srvinfo.sys while starting WinPE?
Which is your WinPE version and which is your VMware Workstation version?

Thanks for responding. Yes i was having the exact same issue with the srvinfo.sys. I to am missing the SATA driver and tried to use double driver and VMware tools and no luck with it matching it. What ended up fixing it was i created a boot ISO and imaged the VM with that. Once i did that i was able to boot to PXE from that same VM and successfully deploy. So it sounds like my binaries never built out. Since i haven’t changed anything with my drivers so that was not the issue.

I am running VMware Workstation 14 Pro 14.1.5 build-10950780
I am running MDT WADK version 1803 and MDT 3.10.10

the issue seems to deal with the memory amount of the computer. How much RAM is assigned to the target computer?
If less, could you please try to assign 3GB or more?

I know it’s been a while, but I’m encountering the same today, doing my first OSD-based setup on VMWare ESXi 6.7 Update 2. Bluescreen when booting WinPE 1903 or 1809 via PXE in the virtual machines, but the same VMs boot fine when mounting the Windows 10 or 2016 ISO images directly.

I wanted to update to see whether anyone had a good/repeatable solution, and also to post some progress on obtaining VMWare drivers.

I was able to download VMWare Tools from https://my.vmware.com/web/vmware/details?downloadGroup=VMTOOLS1032&productId=745 , though mounting the installer from inside a running VM should also be workable. I created an Admin Install Point, by executing
setup.exe /a

Early in the setup, you are asked to specify a location to store the administrative installation point. I pointed at E:\VMWare.
Once setup is finished, the extracted drivers are available at E:\VMWare\VMWare\VMWare Tools\VMWare\Drivers

I’m still not certain whether that will help, but wanted to post an update on at least being able to obtain & import the VMWare drivers in a “clean” way.

the issue occurs on vmware virtual machines later than version 8, when the computer is booted in BIOS mode.
To overcome the issue, create the virtual machine with version 8 (it’s a parameter when creating a new virtual machine) or boot the computer in UEFI mode.

1 Like