Office 365 Update not Uncompressing


I am trying to create a package for the March 2022 O365 update using the Manage Software Distribution Dashboard. The data is compressed at one level. There is a large compressed file created. The actual data being compressed is only 2.09 GB and the compressed file is 3.09 GB. When the package is run on an endpoint, the message returned is: “Unable to extract archive file”. Some of the data is extracted. I see it in the __Download folder.

I saw similar once when the entire directory depth of the files to be compressed were deeper than allowed by Windows - 256 characters, if I recall correctly. Is it possible your source had files nested deeper than that?

You might try moving the installation media to a high level directory and rebuilding the software package from that source, or use the bfarchive tool (linked from!/wiki/BigFix%20Wiki/page/Utilities ) to manually create or extract the archive to see whether any useful error messages are given.

Thanks Jason. I will try using a shorter path.

It is my understanding that the standard decompress in the SWD can only handle up to 2 GB. However, my partner was not having an issue with the January update which was about the same size.

The path is 121 and the limit is 256. I have since found out that size limit is 4 Gb.

BFArchive worked. I created the archive with BFArchive, and then I added the following line to the generated code. It is still a mystery to me why the SWD is not working. It worked for the January updates which are about the same size. My only guess are either: 1) it had to do with doing over VPN, or 2) there was a change to the SWD.

// extract any compressed files

extract "O365March32CompressedData.bftemp" "{parameter "baseFolder"}"
1 Like

After working with support, it was discovered that the uploadmanger.exe in the SWD was recently updated. This change has caused an issue for large files.