Msiexec unistall in Windows 7

(imported topic written by blaine91)

I’ve got a piece of software that I want to uninstall from a 64-bit Windows 7 machine. The uninstall string is a simple msiexec /X{product code}. I’ve tried to add a /QN to it, otherwise it will prompt “Are you sure you want to uninstall?” When I do that from a command line, the software uninstalls silently with no user intervention. However, when I try it in a fixlet with an 8.0.627.0 version of the BES Client, it does not uninstall. I tried a number of ways to try to run the action:

waithidden “{pathname of system wow64 folder}\msiexec.exe” /X{{559D2B32-5066-4762-A2F2-52831AC6F67B} /QN /L c:\temp\uninstall-nici64-wow64.txt

waithidden “{pathname of system folder}\msiexec.exe” /X{{559D2B32-5066-4762-A2F2-52831AC6F67B} /QN /L c:\temp\uninstall-nici64-system32.txt

waithidden msiexec /X{{559D2B32-5066-4762-A2F2-52831AC6F67B} /QN /L c:\temp\uninstall-nici64-unprefixed.txt

waithidden “{pathname of system folder & “\msiexec.exe”}” /QN REBOOT=ReallySuppress /L c:\temp\uninstall-nici64-benkus.txt /X{name of key whose (value “DisplayName” of it =“NICI (64 bit)” and name of it starts with “{”) of key “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall” of native registry}

The last version is something I found in a forum message. When I ran these actions, they all seem to be running msiexec, but the uninstall logs are empty. The client log reports each command line succeeded with an Exit Code=1605, which seems to MSIEXEC error of ERROR_UNKNOWN_PRODUCT. I’ve also tried it with out the /L options and even tried by going back to a 7.0.196 version of the client to see if the new session 0 level interface was the problem but got the same results.

I feel like I must be missing something fundamental here.


(imported comment written by khanand91)


you could try:-

waithidden msiexec.exe /X %7B559D2B32-5066-4762-A2F2-52831AC6F67B%7D /qb /l c:\temp\uninstall-nici64-system32.txt

(imported comment written by blaine91)

Using the character code for { and } did not translate according to the BigFix client log. It did return a different error, Exit Code=1619, which looks to be the MSIEXEC error ERROR_INSTALL_PACKAGE_OPEN_FAILED. Both 1605 and 1619 seem to be “Can’t find the uninstaller info,” but the description of 1619 suggests it may not be a valid Windows Installer package, which makes sense since the command it doesn’t seem to be translating the %7D to {.


(imported comment written by JackCoates91)

Hi blaine,

Here’s how to escape curly brackets:

waithidden "{pathname of system wow64 folder}\msiexec.exe" /X{{003BFBBD-6C67-419E-A24D-0DCAFC3A5249}}" /QN /L C:\my-log.txt

Note that’s my test package’s GUID, not yours. As long as you’re at it, you might find this page interesting too:


(imported comment written by blaine91)


It looks like the only difference in your waithidden statement is a second } and " at the end of the GUID. I added that to my attempts and they all again returned with Exit Code=1619.

The forum article you posted is where I got my fourth waithidden statement.


(imported comment written by JackCoates91)

sorry, I’d been using a tiny package and missed that it was returning 1619. Try removing the last } – here’s me removing Blackberry Desktop from my netbook (32 bit OS, mind the missing WOW64):

waithidden "{pathname of system folder}\msiexec.exe" /X{{205A5182-EFC8-4C25-B61D-C164F8FF4048} /QN /L C:\my-log.txt
STATUS: Running action...
Command succeeded (Exit Code=0) waithidden "C:\windows\system32\msiexec.exe" /X{205A5182-EFC8-4C25-B61D-C164F8FF4048} /QN /L C:\my-log.txt
--- Result ---
Evaluation completed successfully!