Mozilla Firefox installed in the user profile

Hello everybody

I’m trying to uninstall mozilla firefox using the followings lines in the action

runhidden {pathname of parent folder of regapps “firefox.exe”}\uninstall\helper.exe /S

waithidden “C:\Users*\AppData\Local\Mozilla Firefox\uninstall\helper.exe” /S

any test worked, apparently the application is installed in the profile for each user.

I saw in windows register from some pc that the issue and show this

\HKEY_USERS\S-1-5-21-2502276632-2587711727-2842499893-8132\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Mozilla Firefox 95.0 (x64 es-ES)

C:\Users\user\AppData\Local\Mozilla Firefox\uninstall\helper.exe

Some idea about how can i do to uninstall it?


If you have Console 10.0.4 or late you can run powershell directly to do this shell script (I’m sure there’s a way to do it in actionscript too, I just have this on the shelf and it’s worked well for me):

stop-process -name firefox -Force
$RegPath = "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall", "HKLM:\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall"

$app = Get-ChildItem -Path $RegPath | Get-ItemProperty | Where-Object {$_.DisplayName -match "Firefox" }
$app.UninstallString | cmd

Hello Sophia,

Thanks you for your help. Sure, i have big fix 10 and copied the lines in one task but obtainde the following error.

At 12:48:01 -0500 - actionsite (http://PANBGFXDBPR.tigopa.local:52311/cgi-bin/bfgather.exe/actionsite)
C:\WINDOWS\system32\WindowsPowerShell\v1.0\powershell.exe -WindowStyle Hidden -ExecutionPolicy Bypass -File "C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData__bes14.ps1"
Error executing script C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData__bes14.ps1: stop-process : No se encuentra ning£n proceso con el nombre “firefox”. Compruebe el nombre del proceso y ejecute de
nuevo el cmdlet.
En C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData__bes14.ps1: 2 Car cter: 1

  • stop-process -name firefox -Force
  •   + CategoryInfo          : ObjectNotFound: (firefox:String) [Stop-Process], ProcessCommandException
      + FullyQualifiedErrorId : NoProcessFoundForGivenName,Microsoft.PowerShell.Commands.StopProcessCommand

The application is installed in the users profile.



Also i saw and copied the ps script from in a ps file and is working. When i tried to run directly with power shell script option in big fix, didn’t work.

I continue to testing.


I am working on this right now as well and have only found a way to do it each user folder at a time. Do you have a large number to remove? I am hoping to still find a way to remove them in bulk, but individually has gotten the job done to this point.


I have to remove this app from 300 users. Right now it has worked for me with 5. This’s a little test. The strange thing is that didn’t run directly whit big fix power shell script option in the task, I had to copied in the file and upload to the server and create one task with software distribution.

In the command i use powershell.exe -ExecutionPolicy Bypass -File firefox.PS1 and is ok.