July 2018 patches not getting installed


I am applying July 2018 patches on machines and getting failure for few machines (20-30 machines) and manually also checked on one machine its not getting installed. it shows applicable but not getting installed.

Scenario is, we recently upgraded the build of Win10 machines from 1607,1703 to 1709 build. most of the machines got the latest patches after upgraded. But few machines are resulting failure.

Patches while applying it shows “Pending Restart” but the build number of Win10 is not getting updated and more over after reboots that patch is getting rolled over and shows relevant again.

Need your suggestion.

Since you poked me on this, I’ll give the generic answer when there’s not enough detail in the question.

Try to install the given patches manually, and see what the installer says.

Check the exit codes from the wusa process and google the number.

Try uninstalling then reinstalling the patch. If some files from the patch were reverted to earlier versions by some other product installer this can fix partially-installed updates.

Try using sfc and dism to repair corrupt windows installations.


Thank you for the response.

I tried the first one – checked manually but not getting installed. even I have already mentioned in the above information I shared.
Exit code is none and with Failed status. More over when you reboot patches getting roll back. so patches not being installed and we are trying re-installation and same result.

I am going to check rest information shared by you.
“Using SFC and DISM”

Thank you so much