Inconsistent results with action submitted from REST API

Hi All,

I am having an odd situation where a client is submitting an action to a list of systems, but everytime they submit the action, it does not seem to happen for one of the systems. If I submit the action using the same XML file, it all works fine. I checked their permissions and they do have access to this server in the console.

Here is what the XML file looks like:


<?xml version="1.0" encoding="UTF-8"?>
<BES xmlns:xsi="" xsi:noNamespaceSchemaLocation="BES.xsd">


                <Parameter Name="Version">1.9.5</Parameter>
                <Parameter Name="Command_Line"> some command</Parameter>


No matter how many systems are listed in here, the one system will not work for this one client.

When I check the action, I see all 3 clients listed and 2 will process, but the third does nothing. I do not see failed, not relevant, or anything else. Also when I check the BES client log file, there is nothing listed.

I just logged on to the BES Console to confirm this id has access to it and it does. I tried submitting a custom action from the console and that worked. I then tried submitting the action from the REST API and it does not work for this one system.

Any ideas? I am thinking this might be a PMR.


A bit more info

Looking at the action submitted from the console, I see the message “This action was not executed because the operator who created it is not an administrator of this client”. I checked the Administered Computers tab for this id and the system is listed there.

Very odd.