In place upgrade: unknown command-line option /auto

Trying to test the in place upgrade from Win7 to Win10. Latest MDT (3.10.6), and using Windows 10 x64 B16299.15 (1709). Target validation runs fine. Running the upgrade, it proceeds all the way through the action to the upgradesilent.bat and just hangs. Inspection of the log C:$WINDOWS.~BT\Sources\Panther\setupact.log show that it hangs on:
[0x0640ae] IBSLIB PublishMessage: Publishing message [An unknown command-line option [/auto] was specified.]
When I try an interactive install, I get the same error.
When I run C:\in_place_upgrade\W10x64\setup.exe /?
it shows me all of the command line options, of which /auto upgrade IS one.
Same thing when I run C:\in_place_upgrade\W10x64\sources\setup.exe
This seems like a windows thing versus BigFix specific, but would love to know if anyone else has seen this?

Good morning,
did you check if you are running on the Windows 7 a Language Pack different from the native language of the Windows 10 image? I found out this link on technet:

I hope this helps

Good Morning,
I did further tests and investigation. My idea, I am not 100% sure about that, is that setup.exe, scanning the Windows 7 machine, finds something not compatible with Windows 10 or finds there something corrupt. At this link a similar issue when upgrading to Windows 2016 from Windows Server 2012 R2 is described:

My suggestion is to run to some health check and recovery on the Windows 7 machine, but I understood that they can not guarantee a complete recovery.

Moreover, if you run setup.exe without switches, it would display a message that “this upgrade path is not supported” (see attached picture), then my guessing about the behavior you reported and that would be independent from BigFix OSD. If you select upgrade at this point of the wizard, upgrade_choice, following screen will show you this message: inPlaceUpgrade_Error that let me suspect about a corruption in the Windows 7 machine or in a failure, unfortunately not clearly identified, in compatibility check.
I hope this may help, regards