IBM BigFix Remote Control for Broker


I’m unable to take remote control of the machine outside the network. After downloading TRCController.jnpl file from Remote Controller web browser → Target → Start Broker Session. When I’m running .jnlp file (requires Java Installed on controller machine) it’s throwing below error.

Tried with the step mentioned in the below URL but didn’t helped.

Also, Update certificate under Admin → New Trusted Certificate
Not Before: Fri Mar 31 17:22:50 IST 2017
Not After: Sat Mar 31 17:22:50 IST 2018

Tried with changing the parameter for “” as mentioned but no luck.
Any idea on this will be highly appreciated.

@Nagaraj, As you’ve faced the issue earlier I was wondering if you could help me in what settings do I really need to change in “” to make it working…!!

check at TRC server certificate file, in that file it may be generate by IP (or) another host name mean will get the above error while launching on-demand link.


You probably need to register the broker’s certificates with the server. Log in as admin and go to Admin -> Add new trusted certificate. If you’re using self signed certificates for the broker, copy/paste the broker’s certificate. Otherwise, copy/paste the root CA certificate.