How to customize fixlet

Hi all,

I am working with BigFix 9.0.8, I want to customize the Fixlet, e.g. the no. of days of Max/Min password age.
According to IBM doc there is an option to change,
But I can find this on my server. Anyone have idea? Many thanks!!

It’s actually gotten a little simpler since that document. You must have a Custom Copy of the fixlet - usually this is done by using the Custom Checklist Wizard, which will generate an entire Custom Site and clone all of the original Fixlets into the new Custom Site, or you could right-click groups of Fixlets and select the “Create custom copy” option. You cannot modify the original fixlet (including these parameter values) in the IBM-provided External Sites.

When you’re working on the Custom Copy checklist, looking at your screenshot you’d enter the new number in the “Current Value:” textbox, and then click “Apply”. That will update the Fixlet/Task to use your custom value for its relevance & action script.

Thanks JasonWalker. You are right, I copied the fixlets to another custom site, the parameter became editable.

One more problem is, how can I make the fixlet applicable to my client?
Only 3 of the fixlets are applicable, other AIX fixlets are greyed out. Do you have any idea?


You have to edit the relevance of the fixlet that you find here.

You should read through the relevance. When its grey it usually means that the fixlet is not applicable to the servers for reasons you can find in the relvevance for the fixlet.

Many of the AIX / Linux checklists require that you deploy an Action first (preferably, periodically to catch system state changes). This can have an impact on system performance, so take care on the scheduling.

Execute the “Deploy and Run Checklist” task, that generates the data files on the clients which are parsed by the relevance on the other checklist fixlets.

Thanks for JasonWalker and mfuglem.

I changed the Relevance rules, it got Applicable > 0 now.
I also found the value is editable in my custom site.

However, when I change the value and click apply, it shows a script error IE warning, The value will not save. Do I need to make some configuration in IE?


Another problem is, I tried to deploy the fixlet to client, the progress keeps 0% after hours. However, if I restart the Bigfix agent on client computer, it will turn 100%. So strange. How can I make the client check immediately?


That looks like you’d need to open a PMR.

The rest of this is just a guess, I’ve never encountered this before.

There’s an option to “Clear Console Cache”, I believe under the File menu in the console. You might try that to ensure the next time you launch you get a new copy of the site contents downloaded from the server. Could be a missing/corrupt library file.

These descriptions & dashboards are rendered with Internet Explorer, so you might check whether you have a particularly locked-down configuration in your Internet Options control panel.

IBM folks, when IE is doing this rendering, is the source considered “Local Machine Zone” or one of the Internet/Intranet/Trusted Sites zone? Based on how much the console is able to accomplish I expect it’s the “Local Machine” zone.

Normally Local Machine zone is not visible in the Internet Options / Zones listing, but you could still apply lockdown settings with registry keys or Group Policy.

For the second issue (long delay before running action), check whether you have the UDP traffic opened properly in any firewalls/network gear, and on AIX’s firewall. You need to allow UDP-52311 (by default) from the Relay to the Client. The Relay uses this traffic to inform the client whenever site content is updated (including taking Actions).

If UDP is being blocked and you can’t get that opened, see!/wiki/Tivoli%20Endpoint%20Manager/page/Configuration%20Settings for client settings. You’d need your client to poll the server for updates more frequently. By default the client polls either 12 or 24 hours (I forget which), and relies on the UDP notifications for more frequent updates. You can have your client poll more frequently with these settings:


Use these with care, too many clients polling too frequently can impact performance of the client, relay, and root servers. Where I’ve had VPN links blocking the UDP traffic, I’d set this to no more frequently than one poll per hour.

Jason, Thanks for your answers!

The script error is related to the IE ActiveX settings.

Solve after enable ActiveX.

I will study the UDP port issue. Really thanks for your reply!! :grin: