Fixlet Debugger 8.0 Prefetch issue?

(imported topic written by drbyars91)

Just starting playing with the new 8.0.584.0 FixletDebugger. I’m eager to use this tool for initial development of actions prior to deploying on test boxes through the console.

First, thank you for the updates! It helps greatly not to have to modify actions to include a fully qualified path to __Dowload/__creatfile/__appendfile statements.

My primary issue right now is that prefetch doesn’t appear to work. The same prefetch call that is working via a task in the console does not work locally with the new debugger - I receive a "download failed: Failed to prefetch download ‘http://abc’. Is there a trick to get prefetch to work?

My only other feedback would be to enhance the debugger so it would prompt for action parameter queries (not a biggie, it’s easy enough to change as a parameter assignment for debugging purposes) and to include in scope the __Local folder (for actions that use __Local for temporary landing and manipulation of files).

(imported comment written by BenKus)

Can you paste the prefetch command? (make sure you don’t have an extra newline or other syntax issues).


(imported comment written by drbyars91)

I am very sure that there are no extraneous characters in the prefetch statement. The same error is returned with the FixletDebugger using download or download now. We’ve got hundreds of working examples that I’ve tried and it’s very consistent.

I assume from your post then Ben that others do not have issue downloading content with the 8.0 Debugger? I’ve simply unzipped and placed on my desktop, is there a specific location this should reside in?

(imported comment written by JasonHonda)

At the moment, I can’t find a fully up to date list of commands that work in the Action Debugger to verify, but I’m pretty sure that last I checked, ‘prefetch’ is not one of them yet.

However, ‘download’ should work.