Error Uninstalling BigFix Client using Remove BES Client Task

(imported topic written by nicnox91)


I’m having trouble removing BigFix Client from machines when users are logged on.

I am getting the following error:

Bigfix Enterprise Client - InstallShield Wizard

The installer could not read the masthead file from the registry. Installation cannot continue.

We have also tried uninstalling using SMS and the latest BESRemove.exe. If a user is logged off, or a user with admin rights is logged in both solutions work.

I’ve spoken to our local support guy and he has not seen the error before.

Please could you advise firstly if it is possible to uninstall for non-admin users when logged in and secondly have you seen the error or have any idea how we can get around it.

We could request users log out, but that is easier said than done for the number we require to comply! This needs to be removed shortly from a licensing perpective, we may have some issues if this does not complete on all standard clients.

Thank you


(imported comment written by BenKus)

Hi Nikki,

You will need to run the uninstaller or BES Remove as an administrator user.

Perhaps you can use the Task on the BES Support site so that the BigFix Agent will uninstall itself?


(imported comment written by nicnox91)

Hi Ben

Thanks for your response.

SMS is setup to run the program as administrator.

We have now tested this using the ‘Remove BES Clients’ task from BigFix, it throws up the same error unfortuntately.

I can’t find anything regarding this error anywhere, which I guess would suggest its not a very common error.

Anyone have any other suggestions?



(imported comment written by jmlafreniere91)

I have the same issue since I started the rollout of the latest Bigfix client on workstations earlier this week.

The “masthead” error on some workstations, and a double entry of the Bigfix Client under “Add/Remove Programs”.


(imported comment written by jmlafreniere91)

Hello, I’m still waiting for an answer, Bigfix client version 8.0.627.0.



(imported comment written by nicnox91)


My problem doesn’t look as though it was the same issue as yours, no duplicate entry in “Add/Remove programs”

However, I was able to fix my issue by upgrading to the newer version we had This then allowed the removal without users being logged out.

The only problem was, I could not use the bigfix removal as we would of needed to upgrade relays too and due to time constraints this wasn’t feasible.

As you have a newer version anyway, this probably would not relate to you. Might be worth posting a new problem with a new title for more response.



(imported comment written by BGILLEN91)

I am receiving the same error messages on some of my client upgrades from to 8.0.627.0… It seems to have upgraded to the v8 client however it shows v7 in the add/remove programs. I am waiting to hear back from BigFix on the issue…