Download Failed - MoveFiles before running action failed

A few computers have gotten the Download Failed message when attempting to deploy a Honeywell barcode scanner driver. The driver deploys as part of a baseline (action: 158602).

ActionLogMessage: (action:158602) Action signature verified for Execution
ActionLogMessage: (action:158602) MoveFiles before running action failed
ActionLogMessage: (group:158602,action158603) DownloadJobFailed

Does anyone know what causes the above error? Specifically I am interested in the MoveFiles before action running job failed part. If I re-run a new action with the Baseline it’s successful I’m just trying to figure out why it fails the first time sometimes.

It could be due to an antivirus locking the file and not allowing the move operation to complete. The __BESData directory should be excluded from real-time antivirus scanning.
That would explain the sporadic nature of the problem.

Another possibility is that an earlier component in the baseline uses a ‘run’ rather than a ‘wait’ command and leaves a running executable in the __Download folder; but in that case, I’d rather expect a message for 'unable to clear __Download folder".

1 Like

I checked the AV and the entire BigFix folder is excluded. In order to get the Honeywell driver to install silently I had to first download and extract PSEXEC and run the command using the -s system context. I know BigFix already runs it as the system account but I swear this was the only way it would install!

Anyway below is the command I use to extract the PSTOOLs folder. I put it in my own folder in case I need to use it again. I did the same for the Honeywell driver. I think I just answered my own question with: Do you think the method I used to extract it directly to the custom folder is being detected by the AV and breaking it? Edit: Not Trend, nothing in the logs indicating anything got blocked. This ran successfully on 501 computers and download failed on 10 of them.

// sets the source folder (where the installer files will reside)
parameter “SourceFolder” = “C:\Windows\Custom\Software”

// extracts PsTools
if {not exists folder “C:\Windows\Custom\Software\PSTools”}
prefetch db2c823e2ddebbc2a56ca842f67090da2ca807b8 sha1:db2c823e2ddebbc2a56ca842f67090da2ca807b8 size:3189931 http://:52311/Uploads/db2c823e2ddebbc2a56ca842f67090da2ca807b8/PSTools.tmp sha256:b602effb27aa24f9dbf827cd4158119d3b6788ed5b8314726278638d1d142108
extract db2c823e2ddebbc2a56ca842f67090da2ca807b8 {parameter “SourceFolder”}
endif

Can you confirm that the error is following the extract command ? In that case it could be something that prevents writing to the destination directory (your “SourceFolder”). On a failing computer you can also try to enable the client debug logging to see if it collects more info about the error. Use BES Support Fixlet 157 “BES Client Setting: Enable Debug Logging”.

Unfortunately or fortunately it ran successfully a second time on the affected clients so I don’t have a broken one to fix any more. I suspect that if I enabled debug logging the same thing would occur and it would work the second time. This is a tough one to troubleshoot but with only 10 computers having the issue probably not worth the time at this point. Thanks to everyone that tried to help!

Has anyone solved this issue yet? (MoveFiles before running action failed) We see it periodically when running Microsoft security patches. Typically the patch works fine upon re-run. We already have AV exclusions set per HCL recommendations.

At 07:05:22 -0700 -
DownloadsAvailable: checking for 'http://relay:52311/bfmirror/downloads/5206668/0
DownloadsAvailable: false (action id 5206668)
At 07:05:25 -0700 -
DownloadPing command received (ID=5206668)
DownloadsAvailable: checking for 'http://relay:52311/bfmirror/downloads/5206668/0
DownloadsAvailable: true (action id 5206668)
DownloadsAvailable: checking for 'http://relay:52311/bfmirror/downloads/5206668/0
DownloadsAvailable: true (action id 5206668)
ActionLogMessage: (group:5206601,action5206668) Non-Distributed - DownloadsAvailable
ActionLogMessage: (group:5206601,action5206668) Submitting download request
ActionLogMessage: (group:5206601,action5206668) Download url: 'http://download.windowsupdate.com/d/msdownload/update/software/secu/2021/10/windows8.1-kb5006714-x64_403d2e21ee3f257f2127563ee5ea11a34093ec5d.msu
At 07:05:27 -0700 -
ActionLogMessage: (action:5206601) Action signature verified for Execution
ActionLogMessage: (action:5206601) MoveFiles before running action failed
ActionLogMessage: (group:5206601,action5206668) DownloadJobFailed
ActionLogMessage: (group:5206601,action5206668) ending sub action

Unfortunately I don’t have a solution. What I find the most annoying about this issue is that even if you set the action to retry upon failure if it fails to download the first time it never tries again which I guess makes sense since the download isn’t part of the relevance to determine a success.

I opened a case on this issue and received a quick response.

First recommendation was this KB, which I was familiar with and had already addressed. Get rid of disk space issues, file locks, set AV exclusions, and verify permissions.
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0023613

In the next recommendation, they pointed me to this new KB acknowledging a defect.
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0092076

Their work-around of “Start client downloads before constraints are satisfied” isn’t feasible in my specific situation, however I am eagerly awaiting the fix in 10.0.5.

1 Like

Wow thanks for the update! Good to hear that they acknowledged it as a bug and that they are working on a resolution.