Default instance in SQL Database for IBM Endpoint Manager

(imported topic written by VipulSri)


I have recently installed IBM Endpoint manager and facing a lot of issues with its connectivity with database.

At the time of installing SQL server, I gave an instance name rather then using the default instance created in the installation. Will this cause an issue with bigfix communicating to Database?

If yes then what can I do to fix this without doing a clean installation of SQL and IEM.


(imported comment written by GreenEagleLeader)

You can configure the DSN settings on the main IEM server to point to the named instance database.

To do this, open the ODBC editor: If the OS is a 32 bit system, go to Start > All Programs > Administrative Tools > Data Sources (ODBC).

If the OS is a 64 bit OS, open the 32 bit ODBC editor located at C:\Windows\SysWOW64\odbcad32.exe

On the System DSN tab choose the bes_bfenterprise datasource to configure.

In the box: “Which SQL Server do you want to connect to?” enter in the server names \ database instance name. For example if the server name is iemprod01 and the database instance name is iemdatabase01, enter in iemprod01\iemdatabase01

Reply back to this post to confirm if changing the config worked.

(imported comment written by VipulSri)

Thanks for the reply.

It worked fine however I also had to add the bes services dependecies for sql services.

Also after making these changes the error for TCP in the TEM Diagnostic did not go away and after trying so many different things, I had to reinstall SQL and TEM from scratch and using the default instance in SQL which seems to have fixed the TCP error showing in the diagnostic.

I will try the names instance settings on my VM and will update if I am able to fix the issue with TCP.

Thanks again for the suggestion.

(imported comment written by JesperLarsen)


IBM made a guide for manually taking care of stuff like this. Its buried here:!/wiki/Tivoli%20Endpoint%20Manager/page/Remote%20Database%20Guide