Custom Properties not listing all properties via API

Hi all,

When I run https://bigfixserver:52311/api/properties from the API. I do not see the property I am looking for in the list. Though when I run the below query I can see the property specified.

https://bigfixserver:52311/api/query?relevance=(values of it) of property results whose (name of property of it is "Firewall service") of bes computers whose (id of it = 7175657)

Can anyone explain to me why I do not see the value listed when I run the first API call? I imagine the properties are somehow different. I do not see the property listed under custom properties either when I inspect the computer individually in the console, though it is listed under another section. I am running as Master Operator. What am I missing/doing wrong?

I was able to list all properties with the following API call, but it seems all properties should be listed with the /properties call.

/api/query?relevance=(values of it, names of properties of it ) of property results of bes computers whose (id of it = 7175657)