Csscript uninstallation script failing with exit code 1


I am running below command but its getting exit code 1,

waithidden cmd.exe /C cscript /nologo “c:\install\uninstall\uninstall_x64”

can you please suggest how to resolve this issue:-

Your command is returning exit code 1. You haven’t posted anything about what your command does so it’s hard to say why it’s failing.

The most obvious possibility is that the script your running has a dependency on 64-bit components, so you may need to force the client to run without the Wow64 redirection by including this command, anywhere in the action script, before your waithidden command:

action uses wow64 redirection false

Hi Jason,

Thanks for your answer.
I am uninstalling one of our package through csscript but its failing with exit code 1
here is full action script :

Well, that still doesn’t help (at all, I’m afraid).

  • We don’t know what’s inside x64.bfswd
  • We don’t know what your script is doing. The return code “1” is not being created by BigFix, that’s what cscript.exe is giving. And we have no way to know what the cscript.exe is doing because you haven’t posted the content of your script. (except that maybe I do see what’s happening)

Unbelievably, I think I actually do have a tip. Since you’re running ‘cscript /nologo “c:\install\uninstall\uninstall_x64”’ …well … cscript requires that the parameter have a script-type extension. Is that supposed to be uninstall_x64.vbs ? Uninstall_x64.js ?
If you had tried to run these command lines manually, you’d probably get something like

C:\windows\system32>cscript c:\install\uninstall\uninstall_x64
Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.

Input Error: There is no file extension in "c:\install\uninstall\uninstall_x64"
C:\windows\system32>echo %errorlevel%

Thanks that issue resolved as we have to mention full file name:-