Content Errors

(imported topic written by SMcGann)

While logged into the IBM Endpoint Manger Console I start to get an error at every refresh. The error is “Failed to perform mutual authentication” in the expanded details it states:

in background

instruct ‘anonymous namespace’::Refresh

           Failed to perform mutual authentication.

I currently have two separate servers doing the same thing. Possibly after an update.

Any ideas?

(imported comment written by martinc)

This is not one have I seen before.

You mention “possibly after an update”, what type of update? OS patch, database, IEM? Possibly with some added detail, we could help.

I did a google search and I saw this like which refers to this type of error in SCOM
. Maybe it can help,

It is also possible that this may require a PMR.


(imported comment written by SMcGann)

OS patches. Still trying to narrow down the cause. Was hopping someone would recognize the issue for a quick fix. Attached is a screen shot.

(imported comment written by martinc)

Have not seen it before.

There seems to be hits on similar issues

MSDTC fails to mutually authenticate when computers do not run in the same domain:

An old patch:

I notice that you are logging in as a domain user. Do you get the same error as a local user (maybe the master operator account)?

Is the database local to the server or remote?

(imported comment written by SMcGann)

Good catch. I do get a different error when logged on as the master operator.
It also happens at every refresh just like the other error. This is a 2008 R2 domain and the database is local.

Thanks for your help.

(imported comment written by martinc)

Just saw this
. What version are you on?

(imported comment written by SMcGann)

Interesting, this seems to apply, as I have yet to find any issue with functionality. The version of Endpoint Manager I’m using is 9.0.586.0.

(imported comment written by martinc)

Yeah it does say that it does not seem to be an “issue” other than being annoying. Since you are on 586 I think the first think support would recommend is getting on to 787, but that is always easier said than done :slight_smile:

Looking at the change log, there seems to be quite a few authentication fixes between 586 and 649, and then the specific one you just mentioned was addressed in 777.

One other thing. I notice that you are running the console on the IEM server, have you tried running it from a remote system to see what happens?

(imported comment written by SMcGann)

Can you post a link to the change log? I have not tried running if from a remote system, our network design doesn’t make that practical from a deployment stand point. We put these on many small domains.

(imported comment written by martinc)

Sure, here it is:

(imported comment written by SMcGann)

Thanks again for your help!