Console <right click> relevance

(imported topic written by mgelmer23)

I am trying to create a console option to browse to the admin share of the drive that Windows is installed on. There does not seem to be a built-in property that has the information for that, so I created one. No problems with that. The property name is “! Admin Share-SysDrive” and it has a value of “\systemname\C$”

However, when I try to use it as a right click option, I get the error “Not all of the selected computers were able to run the selected action”.

I haven’t had much luck using the session debugger to debug right-click code, so I tried to just echo the value of the property to a text file with a ShellCommandRelevance of this:

“cmd.exe /k echo " & (value of property results whose (name of property of it = “! Admin Share-SysDrive”) of current computer) & " >c:\test.txt”

If I use a property name of “DNS NAME” it works fine, and the system name is put into the test.txt file. If I use my custom property, I get the error. I know BigFix sometimes has problems with characters like “!” so I changed that to “%21”, still no luck.

It seems the problem is with the property I’m using, not the general relevance code, but I’m not sure how to diagnose it any further. The system I’m testing with has returned the proper value for the property, so it is not that it doesn’t exist or has a null value or something.


(imported comment written by BenKus)

Maybe this thread will help?


(imported comment written by mgelmer23)

Thanks Ben

I spent a fair amount of time looking at that posting before submitting this one. Is there a section in that one you can point me to that I overlooked regarding this issue?

(imported comment written by BenKus)

I think post #10 is close to what you want… Ernie used the explorer command… So I think for your example, it would be like:

"cmd.exe /C explorer " & (value of property results whose (name of property of it = “! Admin Share-SysDrive”) of current computer)


(imported comment written by mgelmer23)

Solved - the property was in a “category”, and apparently the relevance query needs to include the cateogry name as well as the property name.

This fails: ! Admin Share-SysDrive

This work: GRP_BF::! Admin Share-SysDrive