Configured email notification for Server Automation?

Has anyone configured email notification for Server Automation? I am looking for an example of email notification in use. I have tried to use the configured install, but not working. I need to know if a log file exists that can tell me if SA is not configured for email correctly. Thanks!

Hi Frank,

So first of all, just the obligatory reference the config documentation on the notification service: http://www.ibm.com/support/knowledgecenter/SS63NW_9.2.0/com.ibm.tivoli.tem.doc_9.2/Platform/Config/sa_commonnotification.html?lang=en
Just to confirm, you followed this but still no joy? Can you tell me what you’ve tried so far?

There are logs for the notification service alright - they are in this directory:

<Server Root Dir>\Applications\Logs

and there’s 2 of them:

  • ns-notifier-app.log: this is for the component in the service that actually send the emails (you should see any failed attempts get logged in here, with hopefully some details why they failed)

  • ns-monitor-app.log: this is for the component in the service that looks for actions containing the notification notation (see here for details). This essentially detects these actions and passes a notification request to the notifier component.

The level of these logs is also configurable in this file.

<Server Root Dir>\Applications\NotificationService\resources\config\nsLogConfig.json

(it may be useful change the “level” properties to “debug” if there’s not enough details showing initially)

The actual configuration of your SMTP server (that you would have set up using fixlet #2240 from the BES Support site) gets written to this file:

<Server Root Dir>\Applications\NotificationService\resources\config\messagingConf.json

Here’s an example of what that file might look like after you’ve run the fixlet. Let’s say you’re using an SMTP server called smtp.acme.com (on port 25) that does not require any authentication to use it (e.g. if it uses a white list of IP addresses, the root server’s being one of the entries):

{
  "smtp":{
    "service": "smtp",
    "host": "smtp.acme.com",
    "secure": false,
    "port": 25,
    "ignoreTLs": false,
    "authMethod": "none",
    "tls": {
      "rejectUnauthorized": false
    }
  }
}

Or another example using gmail’s SMTP server (this does require username/password authentication):

{
  "smtp": {
    "service": "smtp",
    "host": "smtp.gmail.com",
    "secure": false,
    "port": 587,
    "ignoreTLs": false,
    "authMethod": "plain",
    "auth": {
      "user": "XXXX@gmail.com",
      "pass": "U2FsdGVkX1+b/msSA84fLQ1JRxAejivOJZ6AUdTMpFE=|~|"
    },
    "tls" :{
      "rejectUnauthorized": false
    }
  }
}

Maybe look over the logs and the config file examples above and see if anything jumps out at you there.

Cheers,
Paul.

… so actually, all the details in the post above relate to setting up the notification service itself.

Server Automation does integrate with the service to send notifications, and that documentation is here:
http://www.ibm.com/support/knowledgecenter/SS63NW_9.2.0/com.ibm.tem.sa.doc_9.2/ServerAutomation/com.ibm.tivoli.tpm.wkf.doc/Server%20Automation%20plan/sa_notification.html?lang=en

Basically, you enable it using fixlet #152 from the Server Automation site.

That enables it globally, but you then also need to indicate in your automation plan that you want your plan to actually send a notification when it’s completed (or indeed, you can add the Send a Notification fixlet from the BES Support site as a step in the plan if you want to send yourself updates during the execution of the plan). This is done on the Settings tab when defining the plan.

Cheers,
Paul.

thank you,
The ns-nitifier-app.log had something for me to go on. This log was not mentioned in the configuration instructions.
my error:
2016-05-22 05:45:19.592 - error: [500]: [NOT012E] ERROR: Mail not sent because: “Error: Error upgrading connection with STARTTLS”

I will look into this.

Great - thanks for the feedback Frank… I’ll make a note for the documentation team.

Do let us know how you get on.

-Paul.

Good news, the issue was resolved by simply modifying the line with ‘ignoreTLs’ to ‘ignoreTLS’ (note the lettercase) from the messagingConf.json file
I am now getting notifications with my SA jobs!

1 Like